Activity action name is not translated

VERIFIED FIXED in B2G C4 (2jan on)

Status

P3
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: alive, Assigned: alive)

Tracking

({late-l10n})

unspecified
B2G C4 (2jan on)
ARM
Gonk (Firefox OS)
late-l10n

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(2 attachments)

Created attachment 697779 [details]
screenshot of non-translated action

STR:
1. Change language to non-English.
2. Long press in homescreen to select wallpaper

Expected:
The `pick` should be translated

Actual:
The `pick` is in English

Note:
We could only have a workaround in gaia system app to hardcode the action name in l10n properties files now I think.
Triage: BB+, C4, p3
blocking-basecamp: ? → +
Priority: -- → P3
Target Milestone: --- → B2G C4 (2jan on)

Updated

6 years ago
Keywords: late-l10n
Created attachment 698580 [details]
https://github.com/mozilla-b2g/gaia/pull/7307

Patch proposal:
Hard code the translated activity name in system app locale file.

I don't put costcontrol related activity because I don't know how to translate it and I don't think they needs to be translated...
Attachment #698580 - Flags: review?(timdream+bugs)
Attachment #698580 - Flags: review?(l10n)

Comment 4

6 years ago
Comment on attachment 698580 [details]
https://github.com/mozilla-b2g/gaia/pull/7307

How would one test all these strings? I'm concerned that we'll see unfortunate choice of translations if we can't give context. Best would be to add a comment to each on how that string is triggered.

"New with" doesn't sound like English. I've got doubts on "Share to", too, not sure about the others without context.
Attachment #698580 - Flags: review?(l10n) → review-
(In reply to Axel Hecht [:Pike] from comment #4)
> Comment on attachment 698580 [details]
> https://github.com/mozilla-b2g/gaia/pull/7307
> 
> How would one test all these strings? I'm concerned that we'll see
> unfortunate choice of translations if we can't give context. Best would be
> to add a comment to each on how that string is triggered.

Alive, please revise the comment at L246 to "Activity selection dialog titles"

> "New with" doesn't sound like English. I've got doubts on "Share to", too,
> not sure about the others without context.

Let's find a native English speaker, preferably someone from UX to correct them :)
(In reply to Axel Hecht [:Pike] from comment #4)
> Comment on attachment 698580 [details]
> https://github.com/mozilla-b2g/gaia/pull/7307
> 
> How would one test all these strings? I'm concerned that we'll see
> unfortunate choice of translations if we can't give context. Best would be
> to add a comment to each on how that string is triggered.

Some are available to test and some aren't until we have more than one the same activity.

> 
> "New with" doesn't sound like English. I've got doubts on "Share to", too,
> not sure about the others without context.

+activity-pick=Pick from
 Long press on the homescreen
+activity-view=View with
 Couldn't test until there's another browser
+activity-test=Test with
Only in UI test->test activity
+activity-share=Share to
Gallery->photo->Share
+activity-new=New with
Unable to test until we have more than one contact app	
+activity-open=Open with
Unable to test until we have more than one music player who could open music files when BT transfer done.
+activity-save-bookmark=Bookmark to
Unable to test until we have more than bookmark receiver.
+activity-record=Record from
Unable to test until we have more than one recoder app
+activity-browse=Browse with
Unable to test until we have more than one photo viewer
+activity-configure=Configure with
Unable to test until we have more than one settings app
+activity-dial=Dial with
Unable to test until we have more than one dialer

c.c. Josh for CORRECT english string input here:)

Comment 7

6 years ago
Sending a needinfo to Josh for the English copy here.
Flags: needinfo?(jcarpenter)
Hi Alive, here are the UX string recommendations:

+activity-pick= Select from:
+activity-view= View with:
+activity-test= Test with:
+activity-share= Share with:
+activity-new= Create with:
+activity-open= Open with:
+activity-save-bookmark=Bookmark to:
+activity-record=Record from:
+activity-browse=Browse with:
+activity-configure=Configure with:
+activity-dial=Dial from:

Thanks!
Flags: needinfo?(jcarpenter)
Comment on attachment 698580 [details]
https://github.com/mozilla-b2g/gaia/pull/7307

Request l10n review again.
Attachment #698580 - Flags: review- → review?(l10n)

Comment 10

6 years ago
Comment on attachment 698580 [details]
https://github.com/mozilla-b2g/gaia/pull/7307

Thanks, r=me, too.
Attachment #698580 - Flags: review?(l10n) → review+
https://github.com/mozilla-b2g/gaia/commit/3a21ed0d2563ab6bcc91bb01ec9be2933025d061

\O/ Let's use filter to respect the action more precisely in coming v1.x or v2.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Duplicate of this bug: 802241

Comment 13

6 years ago
This issue does not reproduce on Unagi, Build ID: 20130113070202
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.