Closed Bug 826605 Opened 7 years ago Closed 6 years ago

Remove GPSDGeolocationProvider.js

Categories

(Core :: DOM: Geolocation, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 866893

People

(Reporter: Dolske, Assigned: cers)

Details

Attachments

(1 file)

I quit my Firefox build, and got the following error:

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "this.outputStream is null" {file: "file:///Users/dolske/build/mozilla-central/obj/dist/NightlyDebug.app/Contents/MacOS/components/GPSDGeolocationProvider.js" line: 119}]' when calling method: [nsIGeolocationProvider::shutdown]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data: yes]
************************************************************

This surprised me, because I thought GPSD was a Linux thing. I've no idea what it expects to be talking to on OS X!

dougt says that we should just stop shipping this entirely, and let it be an addon if people want it. He is smart and wise when it comes to bacon and geolocation.
Assignee: nobody → csonne
Status: NEW → ASSIGNED
This should remove GPSDGeolocationProvider and all references to it.

I'm a bit unsure if I should have removed the reference in browser/installer/removed-files.in (or indeed added the manifest file in there)

I've emailed Martin McNickle who is as far as I can tell the original author, to let him know that it is being removed.
Attachment #700034 - Flags: review?(dolske)
Comment on attachment 700034 [details] [diff] [review]
Remove GPSDGeolocationProvider

Actually, I should bounce this to mfinkle (for the android bit) and dougt or jdm for the general removal.
Attachment #700034 - Flags: review?(mark.finkle)
Attachment #700034 - Flags: review?(doug.turner)
Attachment #700034 - Flags: review?(dolske)
May I ask what the impact of removing this for Android and B2G?
That's why I bounced this to dougt/mfinkle. I'm not quite sure if this was unused only on Desktop, or if it was also unused on those platforms as well.
Attachment #700034 - Flags: review?(mark.finkle)
Attachment #700034 - Flags: review?(doug.turner)
Attachment #700034 - Flags: review+
Sorry, but I had to back this out along with bug 811469 for xpcshell failures.
https://hg.mozilla.org/integration/mozilla-inbound/rev/adb13d36e50a

https://tbpl.mozilla.org/php/getParsedLog.php?id=18799534&tree=Mozilla-Inbound

TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_multiple_geo_listeners.js | 2 == 1 - See following stack:
TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/test/build/xpcshell/tests/dom/tests/unit/test_multiple_geo_listeners.js | 420 == 42 - See following stack:
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 866893
You need to log in before you can comment on or make changes to this bug.