[FTE] Import contacts form SIM options appears disable even though a SIM with contacts is being used

VERIFIED FIXED in B2G C4 (2jan on)

Status

P1
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: isabelrios, Assigned: kgrandon)

Tracking

unspecified
B2G C4 (2jan on)
x86_64
Windows 7

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Unagi, 12-01-04 build:
Gaia ea325f7
Gecko 257e1c1

PROCEDURE
Flash the device and starts the FTU set up using a valid SIM Card having contacts stored in it

EXPECTED
The option to import contacts from SIM should be available as long as user is using a SIM (even with no contacts)

ACTUAL
The option to import contacts from SIM is always disabled
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?
Sorry, I don't reproduce this with my SIM.

Tried both with a SIM with security enabled and disabled.

Please not that you need a full power off when you insert a SIM card. I had to remove the USB cable and power off the phone to make it recognize the SIM. (no need to pull the battery though).

Bug 825862 landed yesterday and might be related.
blocking-basecamp: ? → +
Priority: -- → P1
Target Milestone: --- → B2G C4 (2jan on)
marking qawanted to have reliable STR.
Keywords: qawanted
(Assignee)

Comment 3

6 years ago
A fix for this was actually landed yesterday, can you update to the latest and try again?

The commit for this is here: https://github.com/mozilla-b2g/gaia/commit/57d92744a97385277a598068eeb4cd743064c1b3

Thanks!
Assignee: nobody → kgrandon
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

6 years ago
(It looks like my commit did not make it into the nightly build, perhaps it will tonight?)
Ah yes, I see, the bug happened only if the SIM security was not enabled, but Kevin fixed it indeed in Bug 825862.

Kevin> it is actually in current nightly, see https://github.com/mozilla-b2g/gaia/commits/nightly

Comment 6

6 years ago
isabel, can you verify this bug is now fixed?
(Reporter)

Comment 7

6 years ago
Unfortunatelly this is not fixed. With today's build, using a SIM Card, that option appears disabled.
Gecko-e39daf3
Gaia-e24d066
(Assignee)

Comment 8

6 years ago
Isabel - Can you confirm that you are able to import contacts into the Contacts app and not FTU? Thanks!
might be a dup of bug 822477
(Reporter)

Comment 10

6 years ago
Yes, that is what is happening. From contacts app you can import but not from FTU
(Assignee)

Comment 11

6 years ago
Yes, possible dupe of bug 822477 - but that bug is covering deactivated sims, or sims that can not connect.

Isabel - Can you confirm that this is an active SIM, and that you can connect to the network with it?
(Reporter)

Comment 12

6 years ago
Sure, it is an active and valid SIM Card with contacts stored.
Sorry, bug 822477 is about the Contact app anyway...
Created attachment 699149 [details]
Import screen before importing
Created attachment 699150 [details]
Import screen after importing
Isabel is testing with an older build, with todays build (Gecko-e39daf3.Gaia-e24d066), seems like it´s working, but is very confusing. Icon and text are greyer than what is desirable, at a first glance looks like is not available, and after importing is greyed out completely. See screenshots attached.
Keywords: qawanted
I definitely don't feel it's too grey but then it is an UX issue that should be moved to another bug.

I noticed also another issue: if you go to next step, and then go back, it's not greyed anymore. But I don't feel this is blocking.

Thanks for testing Carlos !
(Reporter)

Comment 18

6 years ago
2012/28/01 build. Gecko-cfad7c9 Gaia-6c53dfd
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.