when usb is mounted, Device Storage subtitle says "{[ plural(size) ]}"

VERIFIED FIXED

Status

Firefox OS
Gaia::Settings
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: dietrich, Assigned: kaze)

Tracking

({late-l10n})

unspecified
ARM
Gonk (Firefox OS)
late-l10n

Firefox Tracking Flags

(blocking-basecamp:-, b2g18+ fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Reproducible:

* Connect phone to computer via USB cable
* Open Settings/Media storage
* Click USB mass storage enabl...
* Click the back button

Expected: Device storage subtitle shows the space available

Actual: Device storage subtitle shows "{[ plural(size) ]}"
(Reporter)

Updated

5 years ago
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
This persists after you disconnect your device from USB, too - it stays broken until you move to another settings screen & back.  (or quit and reopen settings)

Also: When the USB storage is mounted, if you tap "Device Storage" to dig into more details, it says:
  Total Space   NaN B
  Used          undefined
  Left          undefined

Requesting blocking, as this looks pretty broken.
blocking-basecamp: --- → ?
Created attachment 700075 [details]
screenshot of "{[ plural(size) ]}", just after I've unmounted USB storage
Created attachment 700076 [details]
screenshot of Device Storage settings page, w/ NaN & undefined
(Reporter)

Comment 4

5 years ago
Sad that so broken, but not holding release on it. Would really like to take a fix on approval for this. HINT HINT.
blocking-basecamp: ? → -
(Reporter)

Updated

5 years ago
tracking-b2g18: --- → +
(Assignee)

Updated

5 years ago
Assignee: nobody → kaze
(Assignee)

Comment 5

5 years ago
Created attachment 701116 [details]
patch proposal

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #701116 - Flags: review?(ehung)
Attachment #701116 - Flags: approval-gaia-master?(21)
(Assignee)

Comment 6

5 years ago
https://github.com/mozilla-b2g/gaia/pull/7573
Keywords: late-l10n
Comment on attachment 701116 [details]
patch proposal

r=me, look great. Thanks!
Attachment #701116 - Flags: review?(ehung) → review+
Attachment #701116 - Flags: approval-gaia-master?(21) → approval-gaia-master+
https://github.com/mozilla-b2g/gaia/commit/d7ce771172143cec336def2b2beabcd848c3a4d1
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Verified fixed in 2013-01-24-14-08-59 pvt nightly b2g18 build
Status: RESOLVED → VERIFIED
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.