If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Problems launching the Marketplace app on Firefox OS

RESOLVED INCOMPLETE

Status

Firefox OS
General
RESOLVED INCOMPLETE
5 years ago
5 years ago

People

(Reporter: bsilverberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
While working on gaia-ui-tests for marketplace_login, both stephend and I encountered problems launching the Marketplace app on the phone. The app would launch, and then immediately exit. This happened both when manually launching the app via the icon, and also when launching via Marionette from within an automated test. The frequency of this varies, sometimes it will happen several times in a row and then eventually Marketplace will launch properly. Last night stephend was not able to get it to launch at all, even after flashing his phone.
Here's my Pastie: http://pastie.org/5619908 -- I'll try again after I've re-flashed with today's Unagi engineering build.

Updated

5 years ago
Component: General → General
Product: Marketplace → Boot2Gecko
Version: 1.0 → unspecified
Looks like a gecko bug:

I/Gecko   (  109): [Parent 109] WARNING: waitpid failed pid:513 errno:10: file /data/jenkins/jobs/build-unagi-eng/workspace/gecko/ipc/chromium/src/base/process_util_posix.cc, line 260
I/Gecko   (  109): [Parent 109] WARNING: Failed to deliver SIGKILL to 513!(3).: file /data/jenkins/jobs/build-unagi-eng/workspace/gecko/ipc/chromium/src/chrome/common/process_watcher_posix_sigchld.cc, line 118
I/Gecko   (  109): [Parent 109] WARNING: waitpid failed pid:513 errno:10: file /data/jenkins/jobs/build-unagi-eng/workspace/gecko/ipc/chromium/src/base/process_util_posix.cc, line 260
I/Gecko   (  109): [Parent 109] WARNING: Failed to deliver SIGKILL to 513!(3).: file /data/jenkins/jobs/build-unagi-eng/workspace/gecko/ipc/chromium/src/chrome/common/process_watcher_posix_sigchld.cc, line 118

Chris - Any ideas?
blocking-basecamp: --- → ?
Flags: needinfo?(jones.chris.g)

Updated

5 years ago
Whiteboard: [automation-blocked]
I'm able to launch Marketplace with today's build:

2013-01-04-061439, from 2013-01-04 07:47:01

(Sorry, can't easily get the Git commit info hash.)
(Reporter)

Comment 4

5 years ago
I am still seeing the problem after flashing with today's build.

Updated

5 years ago
blocking-basecamp: ? → ---
tracking-b2g18: --- → ?
That log spew doesn't necessarily indicate gecko bugs; it means we were trying to extra hard to clean up a process that was already cleaned up.

Are there any log messages above that?  Unfortunately https://bugzilla.mozilla.org/attachment.cgi?id=696820 hasn't been uplifted yet, so you can try applying that and see if you get a message.
Flags: needinfo?(jones.chris.g)

Updated

5 years ago
tracking-b2g18: ? → ---

Updated

5 years ago
Keywords: qawanted
Whiteboard: [automation-blocked]
Can't reproduce on 1/4/2013 build. Maybe eng build specific?
bug 827011 has more information. Duping on that. Looks like a regression on today's build.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 827011
Ah okay. Not a dupe then.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Created attachment 711426 [details]
Logcat showing failure to load Marketplace

The steps for this were:

1) Fresh flash of an Unagi engineering build (w/Marionette)
2) Navigate to Settings and connect to Mozilla Guest
3) Wait until you have full Wi-Fi bars/connection established
4) Launch the Marketplace app
Comment on attachment 711426 [details]
Logcat showing failure to load Marketplace

E/GeckoConsole(  110): [JavaScript Error: "self._runningRequest is null" {file: "jar:file:///system/b2g/omni.ja!/components/captivedetect.js" line: 301}] is the likely suspect?
Alive, have you seen comment 9 / comment 10, yourself?  Can you reproduce it?
(In reply to Stephen Donner [:stephend] from comment #11)
> Alive, have you seen comment 9 / comment 10, yourself?  Can you reproduce it?

I've just been pointed to https://bugzilla.mozilla.org/show_bug.cgi?id=752982#c68
This looks like a new bug in relation to Captive Portal. Can you file a new bug and nom it for shira?

I'm going to close this bug as incomplete - I'm having a lot of trouble trying to figure out what to do with this bug - we can't tell what the problem is here. If we get better STR for specific issues (such as comment 10), file new bugs on that.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → INCOMPLETE
Oh wait, I see that comment 12 references the bug comment mentioning what you've seen.
You need to log in before you can comment on or make changes to this bug.