All users were logged out of Bugzilla on October 13th, 2018

Thunderbird doesn't offer to save any passwords; does not use any previously-saved passwords.

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: rebecca.menessec, Unassigned)

Tracking

18 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20130104 Firefox/19.0
Build ID: 20130104084117

Steps to reproduce:

Linux amd64, at least Thunderbird 18.x-19.x -

There is no UI element for offering to save LDAP passwords.


Actual results:

I am prompted for a password every time an LDAP connection is established.


Expected results:

There should be a checkbox or other UI element to save LDAP options, as documented. ( https://wiki.mozilla.org/Thunderbird:Help_Documentation:Connecting_to_an_LDAP_address_book )
(Reporter)

Comment 1

6 years ago
Update: This now appears to be a more major and general bug affecting the password store.

Now Thunderbird is prompting for a password every time I log into the one IMAP server I have set up with this particular installation. I just changed the password for the account. The password has been changed in Thunderbird's password store. (Confirmed with Saved Password Editor addon, viewing the plaintext of the password.)

Do I need to downgrade all the way to the stable release so this works again?
Severity: normal → major
(Reporter)

Updated

6 years ago
Priority: -- → P2
Summary: Thunderbird doesn't offer to save LDAP passwords → Thunderbird doesn't offer to save any passwords; does not use any previously-saved passwords.
(Reporter)

Comment 2

6 years ago
Confirmed that password saving has been broken since sometime after 17.0-stable. Downgraded. Strongly suggest that this be fixed before 18-final. Will be dropping Thunderbird if no action taken.
Severity: major → blocker
Priority: P2 → P1
(Reporter)

Updated

6 years ago
Component: Untriaged → Security
(Reporter)

Updated

6 years ago
Version: 19 → 18
Rebecca, we appreciate that you're seeing a problem in your installation. However, we need to put things into perspective. There are plenty of bugs which are more consequential than yours, and so far we can't even tell if it's a bug or just something about your particular installation or usage. Just raising max-alarm on your problem will not get it fixed any faster. We also need to follow the definition of severity flags:

1) blocker:  Blocks development and/or testing work
2) critical: crashes, loss of data, severe memory leak
3) major:    major loss of function

1) Pls don't set blocking flag unless you know that you're entitled to set it.
2) Your bug isn't critical: no crashes, no dataloss, no severe memory leak involved
3) So if anything, it /might/ be major, or even just a normal annoyance.
Severity: blocker → major
Priority: P1 → --
Putting things into perspective, part 2:

169 password-related bugs of which this bug might be a duplicate

:thun,mail su:password
https://bugzilla.mozilla.org/buglist.cgi?quicksearch=%3Athun%2Cmail%20su%3Apassword;list_id=5462923

Did you verify if your problem has already been reported?
(In reply to Rebecca Menessec from comment #1)
> Update: This now appears to be a more major and general bug affecting the
> password store.
> 
> Now Thunderbird is prompting for a password every time I log into the one
> IMAP server I have set up with this particular installation. I just changed
> the password for the account. The password has been changed in Thunderbird's
> password store. (Confirmed with Saved Password Editor addon, viewing the
> plaintext of the password.)

I'm surprised that you're using an Addon to view plaintext passwords of IMAP account. TB offers an inbuilt UI to do just that, here:

Tools > Options > Security > Passwords > Saved Passwords > Show Passwords

Using addons just increases the likeliness of addon problems.

Rebecca, please do this:
- Restart TB in safe-mode
https://support.mozillamessaging.com/kb/safe-mode
- Verify all passwords using TB's "Show Passwords" method as explained above in this comment; doublecheck on correct spelling and correct capitalization of passwords (lowercase vs. uppercase characters), as well as server names, user names etc.
- Report back here if you are still seeing your problem when running TB's safe-mode

> Do I need to downgrade all the way to the stable release so this works again?

I'd think stable releases are tagged "stable" for a reason (notwithstanding the bugs they have)... ;)
(Reporter)

Comment 6

6 years ago
(In reply to Thomas D. from comment #5)

* To keep this short: I apologize for misusing the flags.

* I did try in safe mode.

* I maintain a huge list of passwords (just switched to a LastPass account to see if that makes life easier), so using an addon to *keep* passwords visible in plaintext by default makes my life easier. (I am very conscious of my environment, and shoulder-surfing.)

* I did try disabling addons in and out of safe mode. It didn't seem to have any effect.

* Downgrading to the stable release in and of itself appears to fix the problem. I did also downgrade to the "stable" (very buggy, actually) releases of Lightning and the GMail CalDAV provider, so I suppose that could have some effect, though it seems rather unlikely.

* I didn't see an obvious match for this specific problem with not saving or offering to save or using saved passwords, but, as you say, there are quite a lot of bugs.
(Reporter)

Comment 7

6 years ago
One additional note: I'm still using Earlybird on an amd64 Windows 7 machine for a completely different (far larger) set of accounts, and it doesn't appear to have this problem. However, I almost never use it. It does have nearly or exactly the same set of addons; forget which.

The Linux builds don't get a lot of love, obviously--same as the Lightning Linux builds--so I'm wondering if this is solely a Linux or (*NIX builds) problem. Or it may be even an Ubuntu-specific problem, since they continue to insist on using amazingly old builds of libnspr and libnss. I'll try upgrading to Debian (?) builds and report back when I have time. I *think* Debian keep much more recent builds for at least "unstable" or "testing" or whatever they call it.
(Reporter)

Comment 8

6 years ago
...okay, never mind on that whole out-of-date-libraries thing. I think.

localhost ~ [0]# dpkg -l | egrep 'lib(nspr|nss3)'
ii  libnspr4:amd64                                    4.9.4-0ubuntu0.12.10.1                                                      amd64        NetScape Portable Runtime Library
ii  libnspr4-0d:amd64                                 4.9.4-0ubuntu0.12.10.1                                                      amd64        NetScape Portable Runtime Library
ii  libnss3:amd64                                     3.14.1-0ckbi1.93ubuntu.0.12.10.1                                            amd64        Network Security Service libraries
ii  libnss3-1d:amd64                                  3.14.1-0ckbi1.93ubuntu.0.12.10.1                                            amd64        Network Security Service libraries
ii  libnss3-tools                                     3.14.1-0ckbi1.93ubuntu.0.12.10.1                                            amd64        Network Security Service tools

Comment 9

6 years ago
Becky, for the record, this problem exists under Windows as well.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20130117 Thunderbird/19.0
(Reporter)

Comment 10

6 years ago
(In reply to Keith Hanlan from comment #9)
> Becky, for the record, this problem exists under Windows as well.
> 
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20130117 Thunderbird/19.0

I had a funny feeling that it might. Thanks for the confirmation, though. I think I'm going to see what I can do with DAVMail and maybe... http://roundcube.net/ ? ...these days.

Comment 11

5 years ago
(In reply to Rebecca Menessec from comment #6)
> * I maintain a huge list of passwords 

How many?
And tested to be working in version 17?
Flags: needinfo?(rebecca.menessec)
(Reporter)

Comment 12

5 years ago
Magically fixed at some point, apparently.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(rebecca.menessec)
Resolution: --- → WORKSFORME
Rebecca, thanks for reporting back and resolving this.
You need to log in before you can comment on or make changes to this bug.