Redirect back after sign in not working

RESOLVED FIXED

Status

Webtools
Air Mozilla
P2
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: peterbe, Assigned: peterbe)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

5 years ago
If I enter a URL whilst not being logged in it takes me to the page says it's protected. From there, I'm asked to sign in which I do. Successfully. 
Then once I've signed in it redirects me back to the home page. Not to the private event I set out to reach in the first place.
Priority: -- → P3
Priority: P3 → P4
(Assignee)

Updated

4 years ago
Priority: P4 → P2
(Assignee)

Comment 1

4 years ago
This is still a problem. An annoying one.
Assignee: nobody → peterbe
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
The problem is that it's not redirecting correctly *before* it gets to the `/login/` page. If you try to go to the management pages it redirects correctly:

E.g.::

 curl -v https://air.mozilla.org/manage/
 ...
 < HTTP/1.1 302 FOUND
 < Location: https://air.mozilla.org/login/?next=/manage/

Bug::

 curl -v https://air.mozilla.org/mwc-2014-staff-logistics-meeting/
 < HTTP/1.1 302 FOUND
 < Location: https://air.mozilla.org/login/

See, it's missing the `?next=/...`

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.