If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Page doesnt print correctly and occasional crashes

VERIFIED INVALID

Status

()

Core
Printing: Output
--
critical
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: johann.petrak@gmail.com, Assigned: dcone (gone))

Tracking

({crash, pp})

Trunk
mozilla0.9.3
x86
Linux
crash, pp
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Build: 2001052213
(Problem already described in later comments in
http://bugzilla.mozilla.org/show_bug.cgi?id=71976)

Printing http://www.mozilla.org/docs/mozilla-faq.html with default
parameters and paper size "legal" results in a document that has
just the header, banner image and footer on page one.
Page one is otherwise empty and the text of the html page
only occurs on page 2.
If printing on A4, the text is on the first page (but
the top margin is wrong, see bug
http://bugzilla.mozilla.org/show_bug.cgi?id=82690)
This problem doesnt occur on other, similar pages,
e.g. http://www.mozilla.org/wishlist-faq.html prints
fine on all paper sizes (except for the margins again)

Switching paper sizes and printing the page several
times in a row also causes occasional chrashes. These
seem to be related to the problem of text not being
included on the first page, because I dont get these
crashes on other URLs, where the text IS printed on
the first page.
(Reporter)

Updated

17 years ago
Summary: Page doesnt print correctly, problems with margins and occasional crashes → Page doesnt print correctly and occasional crashes
(Reporter)

Comment 1

17 years ago
Created attachment 36111 [details]
Printout of http://www.mozilla.org/docs/mozilla-faq.html on legal paper (gzipped postscript)
(Reporter)

Comment 2

17 years ago
Created attachment 36112 [details]
printout of http://www.mozilla.org/docs/mozilla-faq.html, pages 1-2 on a4
(Reporter)

Updated

17 years ago
Keywords: crash

Comment 3

17 years ago
Reporter, could you attach a stacktrace for the crash or a talkback ID?
Severity: normal → critical
(Reporter)

Comment 4

17 years ago
I dont know how to produce either one. No core file is produced after
the crash (though coredumpsize is unlimited)
I installed the ..-sea package (BUILD 2001052421) 
to get the talkback component, and started from a completely new
installation (all .mozilla deleted, no NS 4.x profile copied)
but nothing seems to change: I get something like
   run-mozilla.sh: line 72: 11898 Segmentation fault
on the terminal where I started mozilla, but no talkback window
opens? Can this be activated/deactivated somewhere?

Here  the complete log of what I get on the terminal from the
time the URL is loaded (browse to this URL, file->print, change
printer to ghostview -, click "print", exit ghostview, file->print
again, change paper size to A4, click "print" ... crash!)

Document http://www.mozilla.org/docs/mozilla-faq.html loaded successfully

PPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPPP
top 0.500000 bottom 0.500000 left 0.500000 right 0.500000

PreWidth = 8.500000 PreHeight = 11.000000

Width = 612 Height = 792
dpi 72.000000 top 36 bottom 36 left 36 right 36
/..../mozilla-sea/run-mozilla.sh: line 72: 11931 Segmentation fault      $prog
${1+"$@"}
Exit 139

Comment 5

17 years ago
Adding pp keyword as the reporter told me in email that this bug is occuring
only on Linux.
Keywords: pp

Comment 6

17 years ago
I get the same problem with:

Mozilla/5.0 (X11; U; Linux 2.4.4 i586; en-US; rv:0.9; Debian/GNU) Gecko/20010520
(Reporter)

Comment 7

17 years ago
Retried with build 2001052908
This time talkback works - talkback IDs:
TB31091639E: crash immediately after leaving ghostview after printing
  to "ghostview -"
TB31091981W: printing above URL first to "lpr" (the default) with paper
  size letter (the default), then same URL again to paper size A4 -> crash

Comment 8

17 years ago
We have talkbacks, it is confirmed... marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 9

17 years ago
this bug has to many problems in it.  
The first complaints are duplicate bugs related to table layout.  The crashing 
bugs can be duplicate of table related crashes that sometimes happen.  I dont 
know what needs to be fixed here, and we have fixed a few crashers since those 
talkback reports.. having to do with table and URL names, and printing 
multiple printing jobs in a row.  I am marking this bug as invalid because it 
addresses way to many problems which seem like duplicates.  Please file 
individual bugs for the problems that still are around.. check for duplicates 
for the pagenation bugs (karnaze has a few related to printing tables and the 
pagenation not working.. one item per page, etc)
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Updated

17 years ago
Target Milestone: --- → mozilla0.9.3

Comment 10

17 years ago
please mark this bug VERIFIED-FIXED if you agree with Dcone's
comments...thanks...open new bugs as necessary.

Comment 11

17 years ago
verified. reopen new bugs as necessary.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.