[SMS] sending spinner reappears on sent messages

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: leif, Assigned: borjasalguero)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0 Iceweasel/16.0.1
Build ID: 20121011223555

Steps to reproduce:

1. Send an SMS
2. Navigate to a different screen (back to main SMS screen, home, anywhere)
3. Return to the conversation view


Actual results:

After hitting send, the blue spinner appears to the right of the message for about a second, and then disappears. The message is received by the recipient shortly afterwards.

Upon returning to the conversation view, the spinner has reappeared next to the message I sent.

Additional notes: I've been using the phone every day since Dec 28. On Dec 29, I was prompted to upgrade (and did) to build 20121226070202 (I believe I was running something from early December previously). I'm relatively sure every SMS I've sent since upgrading to 20121226070202 has exhibited this behavior. After they reappear, the spinners do not ever disappear. The messages I sent prior to upgrading do not have the spinner.


Expected results:

Messages which have been successfully sent should not have the spinner.
(Reporter)

Comment 1

6 years ago
this is similar to bug 822055, but I haven't seen the duplicate message behavior described there.
(Reporter)

Comment 2

6 years ago
Another observation:

Going from the conversation to the home screen and back to the conversation (without going to the message list) just now did *not* trigger it. Going back to the message list and then back to the conversation did.
(Assignee)

Updated

6 years ago
Assignee: nobody → fbsc
(Assignee)

Comment 3

6 years ago
Hi Leif,
This bug was fixed and merged, but I guess that your build it's a little bit old. Could you try again with latest Gecko&Gaia? Thanks!
(Reporter)

Comment 4

6 years ago
Confirmed fixed after I got the update to 20130104something today.

(Although the old messages I sent are still spinning perpetually, messages sent after the update don't.)
(Assignee)

Comment 5

6 years ago
Im gonna close it due to it's fixed and it's confirmed by https://bugzilla.mozilla.org/show_bug.cgi?id=826934#c4 .
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.