Install a large hosted app that preloads the appcache, uninstall it, and install it again - no download notification, app fails to install and spins forever

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
a year ago

People

(Reporter: jsmith, Unassigned)

Tracking

Trunk
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Build: B2G 18 1/5/2013
Device: Unagi

Steps:

1. Install "Hosted App with Appcache Preloading Test Case 4" from http://mozqa.com/webapi-permissions-tests/
2. After install completes, launch the app
3. Uninstall the app from the homescreen
4. Install that app again

Expected:

The app should begin downloading the appcache resources again with a download notification present. After download is complete, the app shall be able to be used.

Actual:

No download notification is seen. The app doesn't ever finish installing either.

Nothing interesting in the logcat.
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?
(Reporter)

Comment 1

6 years ago
Apparently this doesn't consistently happen, but I've seen weird behavior twice so far. I'll keep digging.
Keywords: qawanted
(Reporter)

Comment 2

6 years ago
Apparently can't reproduce anymore. I'll reopen if I get a reproduction.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
blocking-basecamp: ? → ---

Updated

a year ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.