PluginHangUIParent.cpp(119) : error C2440: 'return' : cannot convert from 'nsresult' to 'bool'

RESOLVED DUPLICATE of bug 827262

Status

()

Core
Plug-ins
P1
normal
RESOLVED DUPLICATE of bug 827262
5 years ago
5 years ago

People

(Reporter: Xavier Fung, Assigned: aklotz)

Tracking

20 Branch
x86
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Compile Firefox using Visual Studio 2012 Professional under Windows Server 2012 Datacenter gives error on PluginHangUIParent.cpp.

PluginHangUIParent.cpp
PluginHangUIParent.cpp
processing c:/mozilla-inbound/dom/ipc/jar.mn
c:/mozilla-inbound/dom/plugins/ipc/PluginHangUIParent.cpp(119) : error C2440: 'r
eturn' : cannot convert from 'nsresult' to 'bool'
        This conversion requires an explicit cast (static_cast, C-style cast or
function-style cast)
c:\mozilla-inbound\config\rules.mk:1010:0: command 'c:/mozilla-inbound/obj/_virt
ualenv/Scripts/python.exe -O c:/mozilla-inbound/build/cl.py cl -FoPluginHangUIPa
rent.obj -c -D_HAS_EXCEPTIONS=0 -I../../../dist/stl_wrappers  -DMOZ_HANGUI_PROCE
SS_NAME=\"plugin-hang-ui.exe\"  -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_X
PT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_N
S_NET -DIMPL_THEBES  -DNO_NSPR_10_SUPPORT -DEXCLUDE_SKIA_DEPENDENCIES  -DUNICODE
 -D_UNICODE -DNOMINMAX -D_CRT_RAND_S -DCERT_CHAIN_PARA_HAS_EXTRA_FIELDS -D_SECUR
E_ATL -DCHROMIUM_BUILD -DU_STATIC_IMPLEMENTATION -DOS_WIN=1 -DWIN32 -D_WIN32 -D_
WINDOWS -DWIN32_LEAN_AND_MEAN  -DCOMPILER_MSVC -DFORCE_PR_LOG -Ic:/mozilla-inbou
nd/dom/plugins/ipc/../base -Ic:/mozilla-inbound/xpcom/base/  -Ic:/mozilla-inboun
d/dom/plugins/ipc/hangui -Ic:/mozilla-inbound/widget/shared  -Ic:/mozilla-inboun
d/ipc/chromium/src -Ic:/mozilla-inbound/ipc/glue -I../../../ipc/ipdl/_ipdlheader
s  -Ic:/mozilla-inbound/dom/plugins/ipc -I. -I../../../dist/include  -Ic:/mozill
a-inbound/obj/dist/include/nspr -Ic:/mozilla-inbound/obj/dist/include/nss
 -TP -nologo -W3 -Gy -Fdgenerated.pdb -wd4345 -wd4351 -wd4800 -wd4819 -we4553 -G
R-  -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -O1 -Oy-  -Ic:/mozilla-inbound/obj/d
ist/include/cairo -MD            -FI ../../../dist/include/mozilla-config.h -DMO
ZILLA_CLIENT  c:/mozilla-inbound/dom/plugins/ipc/PluginHangUIParent.cpp' failed,
 return code 2
<domplugins_s.lib.desc>: Found error
<libs>: Found error
<../../../staticlib/domplugins_s.lib.desc>: Found error
<libs>: Found error
c:\mozilla-inbound\config\makefiles\target_libs.mk:27:0: command 'c:/mozilla-bui
ld/python/python.exe c:/mozilla-inbound/build/pymake/pymake/../make.py -C plugin
s/ipc libs' failed, return code 2
<libs>: Found error
MediaModule.cpp
MediaModule.cpp
c:\mozilla-inbound\obj\dist\include\nsIDOMMediaStream.h(31) : warning C4002: too
 many actual parameters for macro 'GetCurrentTime'
processing c:/mozilla-inbound/dom/src/jar.mn
c:\mozilla-inbound\config\makefiles\target_libs.mk:18:0: command 'c:/mozilla-bui
ld/python/python.exe c:/mozilla-inbound/build/pymake/pymake/../make.py -C dom li
bs' failed, return code 2
c:\mozilla-inbound\config\rules.mk:609:0: command 'c:/mozilla-build/python/pytho
n.exe c:/mozilla-inbound/build/pymake/pymake/../make.py libs_tier_platform' fail
ed, return code 2
c:\mozilla-inbound\config\rules.mk:574:0: command 'c:/mozilla-build/python/pytho
n.exe c:/mozilla-inbound/build/pymake/pymake/../make.py  tier_platform' failed,
return code 2
c:\mozilla-inbound\client.mk:360:0: command 'c:/mozilla-build/python/python.exe
c:/mozilla-inbound/build/pymake/pymake/../make.py -s -j4 -C c:/mozilla-inbound/o
bj' failed, return code 2
c:\mozilla-inbound\client.mk:160:0: command 'c:/mozilla-build/python/python.exe
c:/mozilla-inbound/build/pymake/pymake/../make.py -f c:/mozilla-inbound/client.m
k realbuild' failed, return code 2

Updated

5 years ago
Assignee: nobody → aklotz
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 827262
You need to log in before you can comment on or make changes to this bug.