Last Comment Bug 827132 - Incorporate nsITransactionManager interface changes (beginBatch, endBatch)
: Incorporate nsITransactionManager interface changes (beginBatch, endBatch)
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Internal Components (show other bugs)
: Lightning 2.2
: All All
: -- normal (vote)
: 2.2
Assigned To: Stefan Sitter
:
:
Mentors:
: 829233 (view as bug list)
Depends on: 617532
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-06 09:28 PST by Stefan Sitter
Modified: 2013-01-14 07:14 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
possible fix (1.04 KB, patch)
2013-01-06 09:38 PST, Stefan Sitter
philipp: review+
philipp: approval‑calendar‑aurora+
Details | Diff | Splinter Review

Description Stefan Sitter 2013-01-06 09:28:31 PST
Bug 617532 changed the interface of nsITransactionManager, e.g. beginBatch() and endBatch() now require parameters being passed in. We have to update our usage in Lightning, e.g. in /calendar/base/src/calTransactionManager.js.
Comment 1 Stefan Sitter 2013-01-06 09:38:23 PST
Created attachment 698447 [details] [diff] [review]
possible fix

Patch not yet tested due to current Thunderbird build errors.
Comment 2 Philipp Kewisch [:Fallen] 2013-01-07 02:24:17 PST
Comment on attachment 698447 [details] [diff] [review]
possible fix

Now that the tree builds again I've tested the patch and it works as expected.

r=philipp
Comment 3 Stefan Sitter 2013-01-07 05:07:04 PST
I won't have time for checkin before evening. Fell free to take over if you want to include the fix in todays nightly build or the branch uplift.
Comment 4 Philipp Kewisch [:Fallen] 2013-01-07 06:29:00 PST
Comment on attachment 698447 [details] [diff] [review]
possible fix

Trees are closed at the moment, I think its ok to just backport this once the merge is done and trees are open again
Comment 5 Stefan Sitter 2013-01-10 12:51:48 PST
*** Bug 829233 has been marked as a duplicate of this bug. ***
Comment 6 Stefan Sitter 2013-01-12 04:42:47 PST
Comment on attachment 698447 [details] [diff] [review]
possible fix

Pushed to https://hg.mozilla.org/comm-central/rev/125efc72f503 for Lightning 2.3.
Comment 7 Ryan VanderMeulen [:RyanVM] 2013-01-12 11:55:16 PST
https://hg.mozilla.org/releases/comm-aurora/rev/198ed4f01f7b

Note You need to log in before you can comment on or make changes to this bug.