Support for unavailable platform in a locale in Firefox languages page

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: trasuntopendiente, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Access System & Languages page in the new sandstone version (available at https://www-demo1.allizom.org/b/en-US/firefox/all/) with product details missing a platform build for any locale (e.g. no Linux build for 17.0.1 in Afrikaans).


Actual results:

An error page would be displayed because build.platforms['Linux'] does not exist.


Expected results:

The old PHP site displayed an Unavailable entry in the table, properly managing errors in product details. An equivalent solution would be desirable.
This is not happening currently, but would make the addition of new platforms in the future more difficult than necessary.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

6 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/771cc0415c13c099286ba2cc13dd79193e03142e
Bug 827133 - Support unavailable builds in new Sandstone Firefox languages page.

Created new unavailable CSS style for unavailable builds in languages page (display: none in 320px screens).
Added macro build_link to all.html to streamline platform column creation.

https://github.com/mozilla/bedrock/commit/e32c76d06dd8e8c6df3f6e5f6ac4ab806905f425
Merge pull request #570 from Elideb/bug-827133-Support-unavailable-platform

Bug 827133 - Support unavailable builds in new Sandstone Firefox languages page.
fixed http://www.mozilla.org/b/en-US/firefox/all/
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.