"ASSERTION: reflow dirty lines failed: 'NS_SUCCEEDED(rv)'" with button, :first-line, flex

RESOLVED DUPLICATE of bug 812822

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 812822
6 years ago
5 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({assertion, testcase})

Trunk
x86_64
Linux
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
(discovered this while tweaking the testcase on bug 824297)

The attached testcase (w/ :first-line and display:flex on a <button>) triggers this in a debug build:

###!!! ASSERTION: reflow dirty lines failed: 'NS_SUCCEEDED(rv)', file layout/generic/nsBlockFrame.cpp, line 1044

If I remove "display:flex", the testcase loads w/out any assertion-failures.

This might end up being the same as bug 824297, but the assertion-failure & style is different, so I figured I'd initially file it separately.
(Reporter)

Updated

6 years ago
Keywords: testcase
Summary: first-line flex → "ASSERTION: reflow dirty lines failed: 'NS_SUCCEEDED(rv)'" with button, :first-line, flex
(Reporter)

Comment 1

6 years ago
This is probably hitting the same issue described in bug 824297 comment 3.
(Reporter)

Updated

6 years ago
Flags: in-testsuite?
(Reporter)

Comment 2

6 years ago
Created attachment 700011 [details]
testcase 1

(oops, just realized I forgot to attach the testcase. here it is.)
(Reporter)

Updated

5 years ago
Depends on: 812822
(Reporter)

Comment 3

5 years ago
Verified that this testcase's assertion is fixed in trunk now, now that bug 812822 has landed.

Marking as dupe of bug 812822, and marking in-testsuite+ because this bug's testcase was included in that bug's crashtests push.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite? → in-testsuite+
Resolution: --- → DUPLICATE
Duplicate of bug: 812822
You need to log in before you can comment on or make changes to this bug.