[Open_]It needs a very long time to wake up the device from suspend

RESOLVED DUPLICATE of bug 823418

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 823418
5 years ago
4 years ago

People

(Reporter: cyvins, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.97 Safari/537.11

Steps to reproduce:

1) Press power key to let the device go to sleep
2) Wait about 2 second
3) Press power key try to wake up the device


Actual results:

It need a very long time(about 6 seconds) to wake up the device.


Expected results:

The device should be wake up in 1 second
(Reporter)

Comment 1

5 years ago
## Environment
* Gaia commit 05b802ed09f3459899fd2210e3472c9afbd1a07b
* Gecko commit 1a362ba230c212ca82578125eab501c278419d83


Kernel Log And Analysis:
<3>[01-07 02:27:13.347] [92: khsclntd][YXS]key_code 0x51, key_parm 0x0                           //-------------kernel detects the power key pressed-------------------------
<4>[01-07 02:27:13.367] [106: b2g][ZYF] lcdc_set_bl level=26, 0
<6>[01-07 02:27:13.377] [106: b2g]request_suspend_state: wakeup (3->0) at 9483485078693 (2013-01-07 02:27:13.390506409 UTC)
<6>[01-07 02:27:13.377] [106: b2g][early_suspend] wq status=1 
<4>[01-07 02:27:13.377] [5843: kworker/u:5][cpufreq] [1]change policy freq from (3c000,f6180) to (f6180,f6180)
<6>[01-07 02:27:13.377] [5843: kworker/u:5]late_resume: call handlers
......
<4>[01-07 02:27:13.528] [5843: kworker/u:5]gequn mipi_lcd_on
<3>[01-07 02:27:13.538] [92: khsclntd][YXS]key_code 0x51, key_parm 0xff
<4>[01-07 02:27:13.628] [5843: kworker/u:5]mipi init start
<4>[01-07 02:27:13.628] [5843: kworker/u:5]LcdPanleID = 266
<4>[01-07 02:27:13.808] [5843: kworker/u:5]lead init ok !!
<4>[01-07 02:27:13.848] [5843: kworker/u:5][ZYF] lcdc_set_bl level=26, 1               
//-------------backlight is on--------------
<4>[01-07 02:27:13.848] [5843: kworker/u:5][LY] before select_1wire_mode
<4>[01-07 02:27:13.848] [5843: kworker/u:5][LY] send_bkl_address 
<4>[01-07 02:27:13.848] [5843: kworker/u:5][LY] send_bkl_data 
<6>[01-07 02:27:13.848] [5843: kworker/u:5]late_resume: handlers level=100 calling kgsl_late_resume_driver
<6>[01-07 02:27:13.848] [5843: kworker/u:5]late_resume: handlers level=100 calling start_drawing_late_resume
<6>[01-07 02:27:13.858] [5843: kworker/u:5]late_resume: handlers level=92 calling msmsdcc_late_resume
<6>[01-07 02:27:13.858] [5843: kworker/u:5]late_resume: handlers level=91 calling msmsdcc_late_resume
<6>[01-07 02:27:13.858] [5843: kworker/u:5]late_resume: handlers level=51 calling kxtik_earlysuspend_resume
<6>[01-07 02:27:13.858] [5843: kworker/u:5]late_resume: handlers level=51 calling cyttsp_ts_late_resume
<6>[01-07 02:27:13.858] [5843: kworker/u:5]late_resume: handlers level=50 calling ath6kl_late_resume
<6>[01-07 02:27:13.858] [5843: kworker/u:5]late_resume: handlers level=30 calling hibernate_late_resume0
<6>[01-07 02:27:13.858] [5843: kworker/u:5]late_resume: done
。。。
<6>[01-07 02:27:19.153] [6653: wpa_supplicant]ath6kl_cfg80211_scan() bssfilter set all bss filter*****   
//--------About 5 seconds later, the screen display all content normally.----
<6>[01-07 02:27:19.153] [6653: wpa_supplicant]ath6kl_cfg80211_scan() n_channels = 13


Others:
The time will be shorter when screen lock is disabled.
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Summary: [Open_]It need a very long time to wake up the device from suspend → [Open_]It needs a very long time to wake up the device from suspend

Comment 2

5 years ago
I believe it's a duplicate case
Whiteboard: DUPEME

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 823418

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.