Wifi: ap list in settings is empty

RESOLVED FIXED in Firefox 21

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: kk1fff, Assigned: gwagner)

Tracking

unspecified
B2G C4 (2jan on)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

This bug happens in current inbound and central branches, but not in b2g18 branch.

STR:
1. Open Settings App.
2. Choose Wifi

Expected: Available Wifi aps are listed in "Available networks".

Actual: "Available networks" stops in "Searching...".

Note: If we turn off Wifi in Setting, we are not able to turn on again before rebooting the phone.
qawanted to find regression range in where it broke.
Keywords: qawanted, regression, regressionwindow-wanted
Bluetooth has the same problem. Turning on Bluetooth would disable the switch button and it would be unable to be switched again.
Gregor is on this. The regressor is a settings service change.
Assignee: nobody → anygregor
Wouldn't hold release on it but bb+ to streamline landing.  This is severely affecting developers.
blocking-basecamp: ? → +
(Assignee)

Comment 6

6 years ago
Created attachment 698640 [details] [diff] [review]
patch
Attachment #698629 - Attachment is obsolete: true
Attachment #698640 - Flags: review?(bent.mozilla)
Component: Gaia::System → General
Comment on attachment 698640 [details] [diff] [review]
patch

Review of attachment 698640 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/settings/SettingsService.js
@@ +55,5 @@
>            let message = info.message;
>            if(typeof(value) == 'object')
>              debug("object name:" + name + ", val: " + JSON.stringify(value));
> +          let checkKeyRequest = store.get(name);
> +          

Nit: whitespace here and a few lines down.

@@ +56,5 @@
>            if(typeof(value) == 'object')
>              debug("object name:" + name + ", val: " + JSON.stringify(value));
> +          let checkKeyRequest = store.get(name);
> +          
> +          checkKeyRequest.onsuccess = function (event) {

Need an onerror handler too.

@@ +70,3 @@
>  
> +            req.onsuccess = function() {
> +              debug("set on success");

Nit: if (DEBUG) this
Attachment #698640 - Flags: review?(bent.mozilla) → review+
(Assignee)

Comment 8

6 years ago
Created attachment 698645 [details] [diff] [review]
patch
Attachment #698640 - Attachment is obsolete: true
Attachment #698645 - Flags: review+
(Assignee)

Comment 10

6 years ago
https://hg.mozilla.org/mozilla-central/rev/206ab8775b40
Status: NEW → RESOLVED
Last Resolved: 6 years ago
status-firefox20: --- → fixed
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Keywords: qawanted, regression, regressionwindow-wanted
Duplicate of this bug: 827365
status-firefox19: --- → wontfix
Target Milestone: --- → B2G C4 (2jan on)
Duplicate of this bug: 827476

Updated

6 years ago
status-firefox20: fixed → wontfix
status-firefox21: --- → fixed
You need to log in before you can comment on or make changes to this bug.