Clipboard is deleted when closing the new private browsing window

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: AlexLakatos, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Steps to Reproduce:
1.Open a new private browsing window
2.Copy something to the clipboard
3.Close the private browsing window
4.Try to paste the clipboard

Actual Results:
5.Clipboard is empty
Expected Results:
5.The contents of the clipboard is pasted

If the clipboard has something in it and there is no interaction with the clipboard in the private browsing window, it is not deleted.
If the private browsing window is still opened, the clipboard filed in that private browsing window can be pasted inside the normal Firefox window.

Comment 1

6 years ago
This sounds like expected behaviour to me as long as the data being copied originates from a private window.
(Reporter)

Comment 2

6 years ago
If that is expected behavior, then data should not be copied when the private browsing window is still opened, which is currently possible.

But as a user, I do need my data to be in the clipboard after I close the private browsing window. That's how I found this out.

Comment 3

6 years ago
The same behaviour existed with the global private browsing mode. Data copied from private windows is deemed sensitive and cleared when no more private windows exist.

Comment 4

6 years ago
Yeah this behavior is expected.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID

Comment 5

5 years ago
Mozilla, thank you for transforming into the new Microsoft "this features works as intended"
#462106
#816998
#827260
#849799
#410669
You need to log in before you can comment on or make changes to this bug.