Regression in CSS3 animations when zooming

RESOLVED DUPLICATE of bug 824454

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 824454
6 years ago
6 years ago

People

(Reporter: julienw, Assigned: nrc)

Tracking

Trunk
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 698603 [details]
index without a meta viewport

STR:
* open index-noviewport.html in B2G's Browser

Expected:
* the rotating text and the non-rotating text should be of the same size

Actual:
* the non-rotating text has the expected size but the rotating text has not


Now, try to zoom in: both texts zoom in during the zoom animation, but as soon as the zoom animation finishes, the rotating text gets back its initial size.

Now, open index-viewport.html: we can see that the initial size is the expected one, but for the rotating text, it is actually the same that in index-noviewport.html. If you try to zoom in, there is the same behavior than before: both texts zoom in, but the rotating text gets the initial size back after the zoom animation.

This is pretty bad as it most probably breaks the web, so nominating BB+.
(Reporter)

Comment 1

6 years ago
Created attachment 698604 [details]
index with a meta viewport
(Reporter)

Comment 2

6 years ago
Assigning to Nick as he might know something.
Assignee: nobody → ncameron
(Reporter)

Updated

6 years ago
Attachment #698604 - Attachment description: inex with a meta viewport → index with a meta viewport
(Reporter)

Comment 3

6 years ago
ccing andrew who can triage this bug.
Nick's got a few other blockers so let's see if Jet can find someone to work on this.
Assignee: ncameron → bugs
blocking-basecamp: ? → +
The rotating and non-rotating text look the same size to me in a B2G build from a few hours ago.

But I'm also unable to figure out how to make the browser zoom.  Is a multi-touch zoom gesture supposed to work?  I thought it was, but it's not working for me right now.
(Reporter)

Comment 6

6 years ago
it does look initially the same in the test case with the viewport but not in the other one. otherwise, the pinch and zoom is supposed to work but you can't zoom out in the example with view port which could be another bug.

Comment 7

6 years ago
Who is working on this?
(Assignee)

Comment 8

6 years ago
(In reply to Andreas Gal :gal from comment #7)
> Who is working on this?

I should be able to get on this tomorrow, unless Jet has someone else for it.
(Assignee)

Comment 9

6 years ago
Also, there is a possibility that the fix I'm working on for bug 824454 will fix this.

Comment 10

6 years ago
(In reply to Nick Cameron [:nrc] from comment #9)
> Also, there is a possibility that the fix I'm working on for bug 824454 will
> fix this.

OK, assigning to you for now. If not a dupe, please update.
Assignee: bugs → ncameron
(Assignee)

Comment 11

6 years ago
My patch for bug 824454 fixes this, so marking as a dup.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 824454
You need to log in before you can comment on or make changes to this bug.