If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

TypeError: this._toolboxes is undefined: @resource:///modules/devtools/gDevTools.jsm:166 if quitting while the web console is open

RESOLVED DUPLICATE of bug 821732

Status

()

Firefox
Developer Tools: Framework
RESOLVED DUPLICATE of bug 821732
5 years ago
5 years ago

People

(Reporter: bz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

BUILD: Opt mac build from inbound rev c6d11daac3fb

STEPS TO REPRODUCE:

1)  Start the browser from a terminal.
2)  Load about:blank (may not matter; I see this on all pages).
3)  Option+Cmd+K
4)  Once the web console opens, Cmd-Q

EXPECTED RESULTS: No terminal spew.

ACTUAL RESULTS:

TypeError: this._toolboxes is undefined: @resource:///modules/devtools/gDevTools.jsm:166
@resource:///modules/devtools/EventEmitter.jsm:56
EventEmitter_emit@resource:///modules/devtools/EventEmitter.jsm:100
@resource:///modules/devtools/Toolbox.jsm:615
effort@resource://gre/modules/commonjs/promise/core.js:53
resolveDeferred@resource://gre/modules/commonjs/promise/core.js:125
then@resource://gre/modules/commonjs/promise/core.js:34
resolve@resource://gre/modules/commonjs/promise/core.js:167
resolveDeferred@resource://gre/modules/commonjs/promise/core.js:125
effort@resource://gre/modules/commonjs/promise/core.js:53
resolveDeferred@resource://gre/modules/commonjs/promise/core.js:125
then@resource://gre/modules/commonjs/promise/core.js:34
then@resource://gre/modules/commonjs/promise/core.js:138
resolve@resource://gre/modules/commonjs/promise/core.js:167
resolveDeferred@resource://gre/modules/commonjs/promise/core.js:125
effort@resource://gre/modules/commonjs/promise/core.js:53
resolveDeferred@resource://gre/modules/commonjs/promise/core.js:125
then@resource://gre/modules/commonjs/promise/core.js:34
resolve@resource://gre/modules/commonjs/promise/core.js:167
resolveDeferred@resource://gre/modules/commonjs/promise/core.js:125
effort@resource://gre/modules/commonjs/promise/core.js:53
resolveDeferred@resource://gre/modules/commonjs/promise/core.js:125
then@resource://gre/modules/commonjs/promise/core.js:34
resolve@resource://gre/modules/commonjs/promise/core.js:167
_onWebConsoleClose@resource:///modules/WebConsolePanel.jsm:79
@resource:///modules/HUDService.jsm:142
WC_onDestroyUI@resource:///modules/HUDService.jsm:581
@chrome://browser/content/devtools/webconsole.js:4451
@resource://gre/modules/devtools/dbg-client.jsm:247
@resource://gre/modules/devtools/dbg-client.jsm:88
EV_notify@resource://gre/modules/devtools/dbg-client.jsm:145
DC_onClosed@resource://gre/modules/devtools/dbg-client.jsm:512
LDT_close@chrome://global/content/devtools/dbg-transport.js:231
LDT_close@chrome://global/content/devtools/dbg-transport.js:229
LDT_close@chrome://global/content/devtools/dbg-transport.js:229
_closeTransport@resource://gre/modules/devtools/dbg-client.jsm:252
@resource://gre/modules/devtools/dbg-client.jsm:549
DC_onPacket@resource://gre/modules/devtools/dbg-client.jsm:494
@chrome://global/content/devtools/dbg-transport.js:212
Summary: TypeError: this._toolboxes is undefined: @resource:///modules/devtools/gDevTools.jsm:166 → TypeError: this._toolboxes is undefined: @resource:///modules/devtools/gDevTools.jsm:166 if quitting while the web console is open
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 821732
You need to log in before you can comment on or make changes to this bug.