Closed Bug 827327 Opened 9 years ago Closed 9 years ago

Remember my permissions for the privileged apis in a privileged app is broken

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-basecamp:+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed)

VERIFIED FIXED
B2G C4 (2jan on)
blocking-basecamp +
Tracking Status
firefox19 --- wontfix
firefox20 --- wontfix
firefox21 --- fixed
b2g18 --- fixed

People

(Reporter: jsmith, Assigned: baku)

References

(Depends on 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files)

Build: B2G 18 1/6/2013
Device: Unagi

Steps:

1. Go to https://marketplace-dev.allizom.org/app/test-webapi-permissions/
2. Install the app
3. Launch it
4. Run the contacts test and remember my choice to allow perms
5. Kill the app
6. Launch it again
7. Access the contacts test again

Expected:

No perm prompt should appear - the perms should automatically be allowed.

Actual:

Perm prompt appears unexpectedly. 100% reproducible.

Additional Notes:

Apparently something went wrong when we wrote stuff to the perm database - I'm only seeing geolocation listed in the settings list. Did something get lost when we wrote these perms to the perm database?
blocking-basecamp: --- → ?
Attached file Logcat
Hmm...something blew up:

01-07 14:56:23.206: E/GeckoConsole(397): [JavaScript Error: "appInfo is null" {file: "jar:file:///system/b2g/omni.ja!/components/AppProtocolHandler.js" line: 69}]
01-07 14:56:23.206: E/GeckoConsole(397): [JavaScript Error: "NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: '[JavaScript Error: "appInfo is null" {file: "jar:file:///system/b2g/omni.ja!/components/AppProtocolHandler.js" line: 69}]' when calling method: [nsIProtocolHandler::newChannel]" {file: "app://homescreen.gaiamobile.org/js/page.js" line: 147}]
01-07 14:56:23.206: E/GeckoConsole(397): [JavaScript Error: "NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: '[JavaScript Error: "appInfo is null" {file: "jar:file:///system/b2g/omni.ja!/components/AppProtocolHandler.js" line: 69}]' when calling method: [nsIProtocolHandler::newChannel]" {file: "app://homescreen.gaiamobile.org/js/page.js" line: 147}]


01-07 14:56:27.726: E/GeckoConsole(1294): [JavaScript Error: "CSP ERROR:  Couldn't parse invalid source 'unsafe-inline'
01-07 14:56:27.726: E/GeckoConsole(1294): "]
Keywords: regression
I just flashed a clean build and retested - 100% reproducible. Something must have blown up really recently - any ideas?
Naoki mentioned that bug 813758 just landed that is talking about permissions - is it related to this possibly?
Jonas thinks bug 811026 might be the root cause of this regression.
Blocks: 811026
Over to Andrea who will investigate, and this is a regression, so blocking.
Assignee: nobody → amarchesini
blocking-basecamp: ? → +
Attached patch patchSplinter Review
Attachment #698873 - Flags: review?(jonas)
Keywords: checkin-needed
Ed - Can you help get this landed on b2g18 as soon as you can? This fixes a bad regression that impacts a bunch of flows for testing, so I want to make sure I get the patch in the next build.
Flags: needinfo?(emorley)
Having a commit message in your patch would make getting it landed faster, for the record...
https://hg.mozilla.org/releases/mozilla-b2g18/rev/35786c2ab673
Flags: needinfo?(emorley)
Target Milestone: --- → B2G C4 (2jan on)
Thanks Ryan :-)
Marking resolved fixed per work week policy for closing bugs when they land on inbound and b2g18.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Keywords: verifyme
QA Contact: jsmith
Andrea, as much as possible, all patches should have tests. This patch could have had a test.
(In reply to Mounir Lamouri (:mounir) from comment #15)
> Andrea, as much as possible, all patches should have tests. This patch could
> have had a test.

Follow-up bug: 827848
Looks like we are remembering permissions again. Marking as verified.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Depends on: 827848
You need to log in before you can comment on or make changes to this bug.