[Email] 'No mail in this Folder' message appearing over inbox with email in it

VERIFIED FIXED in B2G C4 (2jan on)

Status

P3
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: maat, Assigned: squib)

Tracking

unspecified
B2G C4 (2jan on)
x86
Mac OS X

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: interaction [UX-P1])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 698674 [details]
full inbox overlaid with 'no mail in this folder' message

**DESCRIPTION** 
'No mail in this folder' message appearing over inbox with email in it

**PATH**
1) open email app with no email account already set up
2) enter Your name
3) enter email address
4) enter password
5) select Next
6) Select not to add another account

**EXPECTED**
User is taken to their inbox with emails visible

**ACTUAL**
User is taken to their inbox with emails visible BUT the emails are overwritten with the 'No mail in this folder' message.


refer to attachment 'Account Setup'. 
N.B. the two grey oblongs on the screen shot are added by me to remove content
What build?  What account type? Where is the logcat? https://wiki.mozilla.org/Gaia/Email/RequiredBugInfo
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?
Whiteboard: interaction [UX-P1]
(Reporter)

Comment 2

6 years ago
(In reply to Andrew Sutherland (:asuth) from comment #1)
> What build?  What account type? Where is the logcat?
> https://wiki.mozilla.org/Gaia/Email/RequiredBugInfo

Build: 2013016230204
Account: Hotmail
Logcat: is on its way to you via email
logcat says: onsplice notification error TypeError: message.subject is null
displaySubject@app://email.gaiamobile.org/js/message-cards.js:24

The fix for this got merged to gaia/master on Jan 2nd, 2013 on Bug 821447:
https://github.com/mozilla-b2g/gaia/commit/3b2854f1d9a439e3c436adb62facc459e7fcf171

Are you sure your build was what you stated?
Flags: needinfo?(aymanmaat)
(Reporter)

Comment 4

6 years ago
settings > device information > more information

states: 'Build Identifier 2013016230204'
Flags: needinfo?(aymanmaat)
(Assignee)

Comment 5

6 years ago
I assume you mean 20130106230204 (note the third 0)? The build ID you posted doesn't have enough digits.

In any case, this works fine for me with Hotmail, and messages with no subject don't break anything.
(Reporter)

Comment 6

6 years ago
(In reply to Jim Porter (:squib) from comment #5)
> I assume you mean 20130106230204 (note the third 0)? The build ID you posted
> doesn't have enough digits.

typo by me. sorry.
(Reporter)

Comment 7

6 years ago
actually reviewing log cat the error andrew outlines in comment #3 comes before 
update.boot2gecko.org/nightly/b2g_update_20130106230204.mar?build_id=20130106230204&version=18.0, final URI spec: http://update.boot2gecko.org/nightly/b2g_update_20130106230204.mar?build_id=20130106230204&version=18.0, status: 0
E/GeckoConsole(  107): AUS:SVC Downloader:onStopRequest - original URI spec: http://update.boot2gecko.org/nightly/b2g_update_20130106230204.mar?build_id=20130106230204&version=18.0, final URI spec: http://update.boot2gecko.org/nightly/b2g_update_20130106230204.mar?build_id=20130106230204&version=18.0, status: 0

which is interesting as i was firmly under the impression i had updated the device before syncing Hotmail.
(Reporter)

Comment 8

6 years ago
ok so to reproduce the bug i 

1) deleted the hotmail account
2) added the hotmail account (name, email address, password)
3) selected continue to mail on the 'mail account screen'

and what i got was:

a swift appearance of the 'No mail in this folder' message which was removed when the 'loading messages' spinner appeared. When messages were loaded the inbox is now presented without being overlaid with the 'No mail in this folder' message.

i will send me logcat to andrew if he wants to look at it
(Assignee)

Comment 9

6 years ago
That's the expected behavior. The "no mail in this folder" appears because at that point, you're in a fake inbox that we auto-generate for the user. Once we get the real inbox from the server, we start loading the messages, showing the loading spinner.

Since we start fetching the folder list immediately upon creating the account (i.e. when the card with the "Continue" button is displayed), you'll only see the "no mail in this folder" message if you click on the "Continue" button immediately.
blocking-basecamp: ? → +
Priority: -- → P3
Target Milestone: --- → B2G C4 (2jan on)
(Reporter)

Comment 10

6 years ago
(In reply to Jim Porter (:squib) from comment #9)
> That's the expected behavior. The "no mail in this folder" appears because
> at that point, you're in a fake inbox that we auto-generate for the user.
> Once we get the real inbox from the server, we start loading the messages,
> showing the loading spinner.
> 
> Since we start fetching the folder list immediately upon creating the
> account (i.e. when the card with the "Continue" button is displayed), you'll
> only see the "no mail in this folder" message if you click on the "Continue"
> button immediately.

...so therefore we could propose that a significant number of users will see this brief appearance of the "no mail in this folder" message as, if they do not sync another account, there is no reason for them to hang around on the 'mail account screen' and will therefore select 'continue to mail' in order to view the account that they have just syned?

Comment 11

6 years ago
We certainly shouldn't be showing this error unless there is actually no mail in the folder.   A "loading mail" placeholder would be more suitable if we need to show some sort of progress to the user.
(In reply to ayman maat :maat from comment #10)
> ...so therefore we could propose that a significant number of users will see
> this brief appearance of the "no mail in this folder" message as, if they do
> not sync another account, there is no reason for them to hang around on the
> 'mail account screen' and will therefore select 'continue to mail' in order
> to view the account that they have just syned?

The qualified group is people creating ActiveSync accounts on high latency connections.  IMAP accounts won't have this problem.


(In reply to Casey Yee [:cyee] from comment #11)
> We certainly shouldn't be showing this error unless there is actually no
> mail in the folder.   A "loading mail" placeholder would be more suitable if
> we need to show some sort of progress to the user.

We can do this.  Right now, we treat being offline the same as the folder not being syncable, return an error of 'offline' and coerce that to reporting a sync status of 'syncfailed'.  We could instead check "syncable" first (so the case still fires even if we are offline), and report a sync status of 'syncblocked' or something like that which "onStatusChange" in message-cards.js can treat the same as 'synchronizing'.

This will get us our loading message, and we should transparently transition from that fake-synchronizing state to the actual synchronizing state one the folder list synchronizes.

We should also add console.log output to indicate this case, since it will now be possible for us to look like we are loading when we are in fact actually waiting on the folder list to sync and fix everything.
Assignee: nobody → squibblyflabbetydoo
(Assignee)

Comment 14

6 years ago
PRs checked in. These fix the issue where "no mail in this folder" showed up while we were trying to get the folder list in ActiveSync. Now, we just show the loading throbber until everything's done.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 15

6 years ago
Verified fixed on Unagi build 20130112070202.
The "no mail" overlay did not appear when setting up a Hotmail account.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.