Browser crashes when trying to open URL

VERIFIED DUPLICATE of bug 81818

Status

()

Core
ImageLib
--
critical
VERIFIED DUPLICATE of bug 81818
17 years ago
17 years ago

People

(Reporter: Thue Janus Kristensen, Assigned: asa)

Tracking

({crash})

Trunk
x86
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.4 i686; en-US; rv:0.9+) Gecko/20010523
BuildID:    2001052306

Just after telling the browser to go to the URL teh browser crashes.

Reproducible: Always
Steps to Reproduce:
1.Paste the URL into the nav bar and push return.


Actual Results:  It crashes

Expected Results:  I had expected to loose 20 pounds in a week.

This is what the text output says:
---------------------
Document file:///home/thue/hjemmeside/.links.html loaded successfully
Document http://apolyton.net/forums/forumdisplay.php?s=&forumid=97 loaded
successfully
/home/thue/mozilla/run-mozilla.sh: line 72:  7670 Segmentation fault      $prog
${1+"$@"}
bash-2.05$
---------------------

The thing the link points to is possibly undefined; i was messing around. If it
is defined, it is probably a .bmp image.

Comment 1

17 years ago
Win98SE Moz Build 2001051804

I get a blank page at the listed URL but no crash. 

The other URL's mentioned work ok.
(Reporter)

Comment 2

17 years ago
Looking around a bit it turns out there is indeed a .bmp at the end of the URL.
Component: Browser-General → ImageLib

Comment 3

17 years ago
I've crashed on this link with build Win32 2001052404 (on WindowsME).

Confirming and changing platform to All.

The talkback # is TB30913338X
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Updated

17 years ago
Keywords: crash
(Assignee)

Comment 4

17 years ago
   nsImageDocument::UpdateTitle  
[d:\builds\seamonkey\mozilla\content\html\document\src\nsImageDocument.cpp, line
502]
     nsImageDocument::EndLayout
[d:\builds\seamonkey\mozilla\content\html\document\src\nsImageDocument.cpp, line
436]
     ImageListener::OnStopRequest
[d:\builds\seamonkey\mozilla\content\html\document\src\nsImageDocument.cpp, line
187]
     nsDocumentOpenInfo::OnStopRequest
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 255]
     nsStreamListenerTee::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerTee.cpp, line 25]
     nsHttpChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpChannel.cpp, line 2056]
     nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 159]
     PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
     PL_ProcessPendingEvents
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 524]
     _md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 1072]
     KERNEL32.DLL + 0x248f7 (0xbff848f7)  
     0x00688b5e  
     0x00058f64  


blake, I didn't look closely but I saw your name in the blame.  Do you recognize
this or know who should get it?

*** This bug has been marked as a duplicate of 81818 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
It doesn't crash anymore so Verified Linux 2001062021
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.