Copy/paste of "About Firefox" window's build version text no longer works when the window is closed

VERIFIED FIXED in Firefox 20

Status

()

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

({regression})

Trunk
Firefox 21
x86
Mac OS X
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox19 unaffected, firefox20+ verified, firefox21 verified)

Details

(Whiteboard: [fixed by bug 827188])

(Reporter)

Description

6 years ago
STR:
1. Open "About Nightly" window
2. Select the build version text (by double-clicking or click/drag-selecting with mouse)
3. CMD+C to copy the selected text
4. *** Close the "About Nightly" window (with ESC, CMD+W, or clicking the window close button)
5. Try to paste the copied text with CMD+V

RESULT:
Nothing happens because the text was not actually copied to the clipboard! However, if you skip step 4 (i.e. if you leave the "About Nightly" window open when you CMD+V) then the text will be copy/pasted as expected. I have only test Mac OS X 10.8.2.

This bug is a regression in Nightly 20.a1 (2013-01-05). Here is the changelog from 01-04 to 01-05:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=801ba75ac563&tochange=d8ca3e1c469e
(Reporter)

Comment 1

6 years ago
I bisected m-c tinderbox builds to get this narrower regression window:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=38407b98003b&tochange=259982750c29
Crash Signature: 13-01-04
(Reporter)

Comment 2

6 years ago
This bug seems to be an incompatibility with private window bug 815847 and the Test Pilot 1.2.2 addon.

I bisected m-i tinderbox builds to get this even narrower regression window:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2453fdb37bf4&tochange=16c6a3cf8a77

If I disabled the Test Pilot addon, then copy/pasting from the "About Firefox" window (after the window has closed) works correctly.
Crash Signature: 13-01-04
(Reporter)

Updated

6 years ago
Blocks: 815847

Comment 3

6 years ago
Are you opening the About dialog from a private window?

Comment 4

6 years ago
(In reply to Chris Peterson (:cpeterson) from comment #2)
> This bug seems to be an incompatibility with private window bug 815847 and
> the Test Pilot 1.2.2 addon.
> 
> I bisected m-i tinderbox builds to get this even narrower regression window:
> 
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=2453fdb37bf4&tochange=16c6a3cf8a77
> 
> If I disabled the Test Pilot addon, then copy/pasting from the "About
> Firefox" window (after the window has closed) works correctly.

Also, it would be nice if you could bisect further in this range.  This might be coming from parts 3, 4 or 5 in that patch set.
(Reporter)

Comment 5

6 years ago
(In reply to :Ehsan Akhgari from comment #3)
> Are you opening the About dialog from a private window?

No. I have just a non-private window open.
(Reporter)

Comment 6

6 years ago
(In reply to :Ehsan Akhgari from comment #4)
> Also, it would be nice if you could bisect further in this range.  This
> might be coming from parts 3, 4 or 5 in that patch set.

I narrowed down the regression to patch 5 (changeset 16c6a3cf8a77).

Comment 7

6 years ago
Hmm, that means that we probably send last-pb-context-exited too early, which causes the clipboard to get cleared.

Josh, can you think of why that could be?

Thanks for investigating this, Chris!
Blocks: 463027
Flags: needinfo?(josh)

Comment 8

6 years ago
Chris, I just landed bug 827188 on inbound which changes the code in question somewhat drastically.  Can you please retest with that patch and see if you can still reproduce?

Thanks!
(Reporter)

Comment 9

6 years ago
Ehsan, I tested inbound and the problem seems to have been fixed.
status-firefox21: --- → affected
Depends on: 827188

Comment 10

6 years ago
Great, thanks a lot!  Let's call this a dupe for the lack of a better term.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
No longer depends on: 827188
Resolution: --- → DUPLICATE
Duplicate of bug: 827188

Updated

6 years ago
Flags: needinfo?(josh)
Depends + FIXED is a much saner way to track this.
Depends on: 827188
Resolution: DUPLICATE → FIXED
Whiteboard: [fixed by bug 827188]
Target Milestone: --- → Firefox 21
We should track this to ensure it gets caught on 20, as well.
status-firefox21: affected → fixed
tracking-firefox20: --- → +

Comment 13

6 years ago
The fix of bug 827188 was uplifted to Aurora.
status-firefox20: affected → fixed
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0

Verified as fixed in Firefox 20 beta 1 (buildID:20130220104816 ), latest Aurora (buildID: 20130222042021), latest Nightly (buildID: 20130222031133) using STR from comment 0.
status-firefox20: fixed → verified

Comment 15

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20100101 Firefox/21.0

Reproduced this issue with 2013-01-05 Nightly (Build ID: 20130105030839) using steps from comment 0.
Verified fixed on Firefox 21 beta 2 (Build ID: 20130408165307).
Status: RESOLVED → VERIFIED
status-firefox21: fixed → verified
You need to log in before you can comment on or make changes to this bug.