Content-Length is invalid for POST requests over 2GB (file uploads)

VERIFIED DUPLICATE of bug 215450

Status

()

Firefox
Untriaged
VERIFIED DUPLICATE of bug 215450
6 years ago
6 years ago

People

(Reporter: Thomas McGrew, Unassigned)

Tracking

16 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4

Steps to reproduce:

Tried to upload several files via a web upload form, with a total size of ~ 2.1GB


Actual results:

The server was unable to complete the request because Firefox sends a negative number as the value of Content-Length in the POST header.


Expected results:

The Content-Length should be the actual value for the length of the POST request. Chrome exhibits the proper behavior in this instance. I have tested this on both Windows XP and Linux.
You report is for which Firefox version ?
In case you are really using Firefox16 as indicated by the bug header this report is invalid because we accept only reports from the latest version. This should be fixed in FF17 according to bug 215450
Flags: needinfo?(tjmcgrew)
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(tjmcgrew)
Resolution: --- → DUPLICATE
Duplicate of bug: 215450
(Reporter)

Comment 3

6 years ago
I searched for a report on this but was unable to find it. Thanks. And yes, I am currently using FF 16 on Linux. I marked as duplicate.
This report is a good example why we only accept reports from the latest version. This time it was easy since i knew that there is another report but there are other cases where not testing the latest Firefox version can waste hours of time from bug reporters, contributors and developers.

Anyway, thanks for report !
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.