Need checkbox-like icon for Subscribe and Filter dialogs

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Håkan Waara, Assigned: shliang)

Tracking

Trunk
mozilla1.0
x86
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

17 years ago
http://www.mozilla.org/mailnews/specs/filters/images/FilterA1.gif

Look there at the checkbox-like icons. Hewitt said he could "whip something up".

After he has done that, he will assign this to me and I will make it so
subscribe (which currently uses those ugly markers) and the Filter dialog uses it.

Comment 1

17 years ago
that url doesn't work for me.

Comment 2

17 years ago
sorry for the random comment, it's now Bug 82796 www.mozilla.org returning 
corrupted HTTP headers 

Comment 3

17 years ago
Ehhhh ... Please make this apply to all listboxes (rather than subscribe and
filters being inconsistent with other checkboxed listboxes), and just to the
Modern theme. The non-standard checkbox appearance in 4.x always looked a bit
odd compared to the rest of the chrome, but it would fit in with Modern rather well.

The only good reason for using non-standard toggle graphics, that I can think
of, is when you have multiple toggle columns in a single listbox. For example,
where you have the Unread and Flagged columns in the thread pane, you use custom
icons so as to differentiate the columns. But that doesn't apply here.
(Reporter)

Comment 4

17 years ago
mpt, once hewitt decides to fix this bug it will be possible for anything in
Mozilla to use this image. It's easy.
(Reporter)

Comment 5

17 years ago
*** Bug 45312 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
I don't care how easy it is, it would still be inconsistent with every other
checkbox on the platform. Modern isn't bound by such restrictions, but Classic
is supposed to look like a contemporary native app for the platforms on which it
runs. Non-standard checkboxes are a mistake in 4.x which we shouldn't repeat in
Classic.

Comment 7

17 years ago
Created attachment 37049 [details]
w2k's opinion

Comment 8

17 years ago
Created attachment 37050 [details]
and in a control panel applet

Comment 9

17 years ago
Created attachment 37051 [details]
and outlook express's approach
(Reporter)

Comment 10

17 years ago
Indeed I don't think it should matter that this control would be non-standard,
as long as it was obvious that it was clickable and what it did (to toggle a value).

Also, I think having a checkbox-like image would be far better than using a
checkmark, as now.

Comment 11

17 years ago
Created attachment 37052 [details]
whoops. outlook express mail rules

Comment 12

17 years ago
Created attachment 37053 [details]
whoops that was creating a filter, this is enabling them

Comment 13

17 years ago
Well, mpt I know i didn't get the memo from microsoft announcing the flat 
checkbox was in, but I'm guessing it's out there somewhere.

Ok, so what does this prove? (a) microsoft decided that 3d checkboxes inside a 
bevel look bad. (b) the outlook express designers (who most likely were _not_ 
on the w2k team) decided that they wanted to use a different flat checkbox for 
rules.

conclusions? well if mpt can't find at least a few things wrong w/ the oe 
dialogs before he finishes reading this comment i'll eat my hat.

mpt, would you like jglick to try the checkboxes from w2k? or since the ones we 
have happen to look like oe's...

Comment 14

17 years ago
> Well, mpt I know i didn't get the memo from microsoft announcing the flat
> checkbox was in, but I'm guessing it's out there somewhere.

It's in bug 71364, which I filed three months ago. Do try to keep up. :-)

If this bug is the Modern theme counterpart to Windows Classic's bug 71364 
(i.e. a new icon for *all* checkboxes inside listboxes), then great. But if 
this bug is just for the Subscribe and Filter dialogs, then I maintain it 
should be WONTFIXed on the grounds that it will introduce unnecessary 
inconsistency.

Comment 15

17 years ago
no fair, i commented in that bug 3 months ago. it sure looks like it's related 
to that one. too bad we don't have a 'this bug is a sibling to' field.
(Reporter)

Comment 16

17 years ago
I can try and replace as many places as possible when we have an icon, sure.

Updated

17 years ago
QA Contact: esther → laurel

Comment 17

17 years ago
What's the point, when it could be done far more reliably with a selector in 
the relevant Modern CSS file?

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 18

16 years ago
Mass reassigning my theme bugs to Shuehan.
Assignee: hewitt → shliang
Status: ASSIGNED → NEW
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Reporter)

Comment 19

16 years ago
seth fixed this a while ago.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 20

16 years ago
Checkbox-like icon present in both Message Filters and Subscribe dialogs. This
checkbox is present in Modern theme. Classic has just a checkmark, which is
consistent with the 4.x filters and subscribe dialogs display.
Status: RESOLVED → VERIFIED

Comment 21

16 years ago
Verified in nov 19 commercial trunk build: win98, linux rh6.2, mac OS X
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.