youtube.com doesn't recognize B2G UA as mobile

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: lmandel, Unassigned)

Tracking

(Blocks: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [uaoverride] [country-all] [serversniff], URL)

youtube.com serves a desktop site to B2G. Bug 819210 added an UA override for this domain. The override should be removed once the domain serves mobile content to B2G. This bug tracks the evangelism for the site to recognize the B2G UA and the removal of the override at that time.
Blocks: 759982
Whiteboard: [uaoverride]
Here's a pointer to our UA reference: https://developer.mozilla.org/en-US/docs/Gecko_user_agent_string_reference

Specifically, it looks like this: "Mozilla/5.0 (Mobile; rv:15.0) Gecko/18.0 Firefox/18.0"
We currently override the UA to prevent this. So youtube.com receives:
"Mozilla/5.0 (Android; Mobile; rv:15.0) Gecko/18.0 Firefox/18.0
(In reply to Anthony Ricaud (:rik) from comment #2)
> We currently override the UA to prevent this. So youtube.com receives:
> "Mozilla/5.0 (Android; Mobile; rv:15.0) Gecko/18.0 Firefox/18.0

This is intentional. We haven't had a clear request for YouTube for our mobile clients. I spoke with the Firefox for Android team about their requirements. I still need to speak with the Firefox OS team. Once we're clear on the request, we can talk to YouTube and making the changes to support our platform.
(In reply to Lawrence Mandel [:lmandel] from comment #3)
> (In reply to Anthony Ricaud (:rik) from comment #2)
> > We currently override the UA to prevent this. So youtube.com receives:
> > "Mozilla/5.0 (Android; Mobile; rv:15.0) Gecko/18.0 Firefox/18.0
> 
> This is intentional. We haven't had a clear request for YouTube for our
> mobile clients. I spoke with the Firefox for Android team about their
> requirements. I still need to speak with the Firefox OS team. Once we're
> clear on the request, we can talk to YouTube and making the changes to
> support our platform.

See my email started on this with some of the FF OS guys. This has become a bit more urgent to resolve due to a corp bug filed about our YouTube usage on FF OS.
(In reply to Jason Smith [:jsmith] from comment #4)
> See my email started on this with some of the FF OS guys. This has become a
> bit more urgent to resolve due to a corp bug filed about our YouTube usage
> on FF OS.

Agreed. Thanks for pushing to get an answer so that we can get back in touch with YouTube.

Updated

5 years ago
Blocks: 871910
Depends on: 887454
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 887454
We've been treating the evangelism bugs separate from the bugs to modify the UA override list. Not that it's a big deal but I'm going to resolve this as fixed.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Ok. Regardless, we did the evangelism :)
Yes. And much thanks for all the work here.

Updated

5 years ago
Whiteboard: [uaoverride] → [uaoverride] [country-all] [serversniff]

Updated

4 years ago
See Also: → bug 1053712
You need to log in before you can comment on or make changes to this bug.