[Settings][Data Roaming] Can't close data roaming after turned on it.

VERIFIED FIXED in Firefox 21

Status

Firefox OS
General
P2
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: ypwalter, Assigned: swu)

Tracking

({regression})

unspecified
B2G C4 (2jan on)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-basecamp:+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
2012-1-7 b2g18(v1.0) build from pvt server
2012-12-28 date(v1.1) build from pvt server

STR:
  0. Make sure you are using a international SIM card
  1. Go to "Settings" > "Cellular & Data"
  2. Turn on "Data Connection"
  3. Turn on "Data Roaming"
  4. Wait till 3G/E/H sign came out
  5. Turn off "Data Roaming"
  6. Go to "Browser" and browse the internet

expected result: 
  Should show no internet

actual result:
  3G, E, or H sign is still there near the signal icon. You are still able to do data roaming!


That's not good at all. You think you closed the data roaming, but it actually doesn't get closed.
(Reporter)

Comment 1

6 years ago
For v1.0, it should either disable the function if it is OOS so that it won't affect the normal use of this phone. Or, someone should fix it.

For v1.1, it is a blocker since we are going to ship with data roaming in no time.
blocking-b2g: --- → shira?
blocking-basecamp: --- → ?
(Assignee)

Updated

6 years ago
Assignee: nobody → swu
blocking-basecamp: ? → +
Keywords: regression
Priority: -- → P2
Target Milestone: --- → B2G C4 (2jan on)
I'm pretty sure this is a platform bug. Let's add it on their radar.
Component: Gaia::Settings → General
(Assignee)

Comment 3

6 years ago
Created attachment 699171 [details] [diff] [review]
V1

Disconnect data call if roaming turned off when device is roaming.
Attachment #699171 - Flags: review?(vyang)
Attachment #699171 - Flags: review?(vyang) → review+
https://hg.mozilla.org/mozilla-central/rev/383de4872c30
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-b2g18/rev/77ebb9d27dfe
status-b2g18: --- → fixed
status-firefox19: --- → wontfix
status-firefox20: --- → wontfix
status-firefox21: --- → fixed
(Reporter)

Comment 7

6 years ago
Wait, this is strange. Why firefox19 20 wont be fixed?
The Firefox OS won't upgrade soon to firefox 19 or 20?
Why not put the patch in 19 20?
Flags: needinfo?(ryanvm)
No, uplifts are only going onto b2g18. The post-b2g18 FirefoxOS release will come from a later Gecko revision (TBD).
Flags: needinfo?(ryanvm)
(Reporter)

Comment 9

6 years ago
Since it's TBD, why not just patch on those two version to prevent from possible regression?
Because the release drivers said so.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 814417
(Reporter)

Updated

6 years ago
Blocks: 827222
(Reporter)

Comment 12

6 years ago
Verified in pvt b2g-18 nightly build 	2013-01-18-23-02-02
Status: RESOLVED → VERIFIED

Updated

5 years ago
blocking-b2g: shira? → ---
You need to log in before you can comment on or make changes to this bug.