RIL: [JavaScript Error: "oldIcc is null" {RadioInterfaceLayer.js line: 1616}]

RESOLVED FIXED in mozilla21

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: gwagner, Assigned: edgar)

Tracking

unspecified
mozilla21
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
On otoro with american SIM card that can't connect to the network

I/Gecko   (  447): 1357638133600	Marionette	INFO	MarionetteComponent loaded
I/Gecko   (  447): 1357638133647	Marionette	INFO	marionette enabled
I/Gonk    (  447): Socket open for RIL
I/VolumeManager(  447): changing state from 'Uninitialized' to 'Starting'
I/VolumeManager(  447): Connected to vold
I/VolumeManager(  447): Volume sdcard: changing state from Init to Mounted @ '/mnt/sdcard' (1 observers)
I/VolumeManager(  447): changing state from 'Starting' to 'Volumes Ready'
D/VoldCmdListener(   99): volume list
I/AutoMounter(  447): UpdateState: umsAvail:1 umsEnabled:1 mode:0 usbCablePluggedIn:1 tryToShare:0
I/AutoMounter(  447): UpdateState: Volume sdcard is Mounted and inserted
I/Gonk    (  447): Connected to netd
V/EventHub(  447): Opening device: /dev/input/event5
D/EventHub(  447): No input device configuration file found for device '7k_handset'.
I/EventHub(  447): New device: id=1, fd=51, path='/dev/input/event5', name='7k_handset', classes=0x81, configuration='', keyLayout='/system/usr/keylayout/7k_handset.kl', keyCharacterMap='/system/usr/keychars/Generic.kcm', builtinKeyboard=false
V/EventHub(  447): Opening device: /dev/input/event4
D/EventHub(  447): No input device configuration file found for device 'compass'.
V/EventHub(  447): Dropping device: id=2, path='/dev/input/event4', name='compass'
V/EventHub(  447): Opening device: /dev/input/event3
D/EventHub(  447): No input device configuration file found for device 'proximity'.
V/EventHub(  447): Dropping device: id=3, path='/dev/input/event3', name='proximity'
V/EventHub(  447): Opening device: /dev/input/event2
D/EventHub(  447): No input device configuration file found for device 'light'.
V/EventHub(  447): Dropping device: id=4, path='/dev/input/event2', name='light'
V/EventHub(  447): Opening device: /dev/input/event1
D/EventHub(  447): No input device configuration file found for device 'roamer2_keypad'.
I/EventHub(  447): New device: id=5, fd=54, path='/dev/input/event1', name='roamer2_keypad', classes=0x1, configuration='', keyLayout='/system/usr/keylayout/Generic.kl', keyCharacterMap='/system/usr/keychars/Generic.kcm', builtinKeyboard=false
V/EventHub(  447): Opening device: /dev/input/event0
E/filemap (  447): mmap(0,4096) failed: No such device
I/EventHub(  447): New device: id=6, fd=58, path='/dev/input/event0', name='atmel-touchscreen', classes=0x15, configuration='/system/usr/idc/atmel-touchscreen.idc', keyLayout='/system/usr/keylayout/Generic.kl', keyCharacterMap='/system/usr/keychars/Generic.kcm', builtinKeyboard=false
V/EventHub(  447): Reporting device opened: id=6, name=/dev/input/event0
V/EventHub(  447): Reporting device opened: id=5, name=/dev/input/event1
V/EventHub(  447): Reporting device opened: id=1, name=/dev/input/event5
I/InputReader(  447): Device reconfigured: id=6, name='atmel-touchscreen', surface size is now 320x480, mode is 1
I/InputReader(  447): Device added: id=6, name='atmel-touchscreen', sources=0x00001103
I/InputReader(  447): Device added: id=5, name='roamer2_keypad', sources=0x00000101
I/InputReader(  447): Device added: id=1, name='7k_handset', sources=0x80000101
I/Gecko   (  447): 1357638141438	Marionette	INFO	marionette initializing at final-ui-startup
I/Gecko   (  447): 1357638144391	Marionette	INFO	marionette-actors.js loaded
I/Gecko   (  447): 1357638144466	Marionette	INFO	marionette listener opened
I/nsVolumeService(  447): UpdateVolume: '/mnt/sdcard' state Mounted @ '/mnt/sdcard'
I/Gecko   (  447): 1357638145418	Marionette	INFO	onStopListening for Marionette dummy socket, code 2147500036
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): -*- SettingsManager: get lock!
I/Gecko   (  447): WARNING: Unable to test style tree integrity -- no content node: file /Users/Gregor/code/src/layout/base/nsCSSFrameConstructor.cpp, line 8263
E/GeckoConsole(  447): [JavaScript Warning: "TypeError: anonymous function does not always return a value" {file: "chrome://browser/content/shell.js" line: 689}]
E/GeckoConsole(  447): [JavaScript Warning: "TypeError: function alert_receiveMessage does not always return a value" {file: "chrome://browser/content/shell.js" line: 762}]
I/FMRadio (  447): FMRadio is initialized.
I/wpa_supplicant(  340): CTRL_IFACE monitor[0]: 111 - Connection refused
I/wpa_supplicant(  340): CTRL_IFACE monitor[0]: 111 - Connection refused
I/wpa_supplicant(  340): CTRL_IFACE monitor[0]: 111 - Connection refused
I/wpa_supplicant(  340): CTRL_IFACE monitor[0]: 111 - Connection refused
I/wpa_supplicant(  340): CTRL_IFACE monitor[0]: 111 - Connection refused
I/wpa_supplicant(  340): CTRL_IFACE monitor[0]: 111 - Connection refused
I/wpa_supplicant(  340): CTRL_IFACE monitor[0]: 111 - Connection refused
I/wpa_supplicant(  340): CTRL_IFACE monitor[0]: 111 - Connection refused
I/wpa_supplicant(  340): CTRL_IFACE monitor[0]: 111 - Connection refused
I/ONCRPC  (  108): Setup RPC Call for task 401a0468
I/ONCRPC  (  108): oncrpc_xdr_call_msg_start: Prog: 30000000, Ver: ddc9bd91, Proc: 00000014
I/ONCRPC  (  108): xdr_std_msg_send_call: Sent Xid: ec, Prog: 30000000, Ver: ddc9bd91, Proc: 00000014
I/ONCRPC  (  108): xdr_std_msg_send_call: Received Reply Xid: ec, Prog: 30000000, Ver: ddc9bd91, Proc: 00000014
I/ONCRPC  (  108): rpc_handle_rpc_call: for Xid: 13a, Prog: 31000000, Vers: fc37ad5c, Proc: 00000004
I/ONCRPC  (  108): rpc_handle_rpc_call: Find Status: 0 Xid: 13a
I/ONCRPC  (  108): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 13a
I/ONCRPC  (  108): rpc_handle_rpc_call: for Xid: 13b, Prog: 31000000, Vers: fc37ad5c, Proc: 00000012
I/ONCRPC  (  108): rpc_handle_rpc_call: Find Status: 0 Xid: 13b
I/ONCRPC  (  108): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 13b
I/ONCRPC  (  108): rpc_handle_rpc_call: for Xid: 13c, Prog: 31000000, Vers: fc37ad5c, Proc: 00000012
I/ONCRPC  (  108): rpc_handle_rpc_call: Find Status: 0 Xid: 13c
I/ONCRPC  (  108): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 13c
I/ONCRPC  (  108): rpc_handle_rpc_call: for Xid: 13d, Prog: 31000000, Vers: fc37ad5c, Proc: 0000000f
I/ONCRPC  (  108): rpc_handle_rpc_call: Find Status: 0 Xid: 13d
I/ONCRPC  (  108): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 13d
I/ONCRPC  (  108): rpc_handle_rpc_call: for Xid: 13e, Prog: 31000000, Vers: fc37ad5c, Proc: 0000000f
I/ONCRPC  (  108): rpc_handle_rpc_call: Find Status: 0 Xid: 13e
I/ONCRPC  (  108): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 13e
I/ONCRPC  (  108): rpc_handle_rpc_call: for Xid: 13f, Prog: 31000012, Vers: 00040001, Proc: 00000004
I/ONCRPC  (  108): rpc_handle_rpc_call: Find Status: 0 Xid: 13f
I/ONCRPC  (  108): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 13f
I/ONCRPC  (  108): Setup RPC Call for task 401a0468
I/ONCRPC  (  108): oncrpc_xdr_call_msg_start: Prog: 30000000, Ver: ddc9bd91, Proc: 000000b0
I/ONCRPC  (  108): xdr_std_msg_send_call: Sent Xid: ed, Prog: 30000000, Ver: ddc9bd91, Proc: 000000b0
I/ONCRPC  (  108): xdr_std_msg_send_call: Received Reply Xid: ed, Prog: 30000000, Ver: ddc9bd91, Proc: 000000b0
I/ONCRPC  (  108): rpc_handle_rpc_call: for Xid: 140, Prog: 31000000, Vers: fc37ad5c, Proc: 00000004
I/ONCRPC  (  108): rpc_handle_rpc_call: Find Status: 0 Xid: 140
I/ONCRPC  (  108): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 140
I/ONCRPC  (  108): rpc_handle_rpc_call: for Xid: 141, Prog: 31000000, Vers: fc37ad5c, Proc: 0000000f
I/ONCRPC  (  108): rpc_handle_rpc_call: Find Status: 0 Xid: 141
I/ONCRPC  (  108): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 141
I/ONCRPC  (  108): rpc_handle_rpc_call: for Xid: 142, Prog: 31000000, Vers: fc37ad5c, Proc: 00000012
I/ONCRPC  (  108): rpc_handle_rpc_call: Find Status: 0 Xid: 142
I/ONCRPC  (  108): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 142
I/ONCRPC  (  108): rpc_handle_rpc_call: for Xid: 143, Prog: 31000000, Vers: fc37ad5c, Proc: 00000012
I/ONCRPC  (  108): rpc_handle_rpc_call: Find Status: 0 Xid: 143
I/ONCRPC  (  108): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 143
I/Gecko   (  447): WARNING: SQLite returned error code 1 , Storage will convert it to NS_ERROR_FAILURE: file /Users/Gregor/code/src/storage/src/mozStoragePrivateHelpers.cpp, line 79
I/Gecko   (  447): WARNING: SQLite returned error code 1 , Storage will convert it to NS_ERROR_FAILURE: file /Users/Gregor/code/src/storage/src/mozStoragePrivateHelpers.cpp, line 79
I/ONCRPC  (  108): Setup RPC Call for task 401a0468
I/ONCRPC  (  108): oncrpc_xdr_call_msg_start: Prog: 30000000, Ver: ddc9bd91, Proc: 0000009e
I/ONCRPC  (  108): xdr_std_msg_send_call: Sent Xid: ee, Prog: 30000000, Ver: ddc9bd91, Proc: 0000009e
I/ONCRPC  (  108): xdr_std_msg_send_call: Received Reply Xid: ee, Prog: 30000000, Ver: ddc9bd91, Proc: 0000009e
I/ONCRPC  (  108): rpc_handle_rpc_call: for Xid: 146, Prog: 31000000, Vers: fc37ad5c, Proc: 00000004
I/ONCRPC  (  108): rpc_handle_rpc_call: Find Status: 0 Xid: 146
I/ONCRPC  (  108): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 146
E/GeckoConsole(  447): [JavaScript Error: "oldIcc is null" {file: "jar:file:///system/b2g/omni.ja!/components/RadioInterfaceLayer.js" line: 1616}]
(Assignee)

Updated

6 years ago
Assignee: nobody → echen
(Assignee)

Comment 1

6 years ago
Created attachment 699139 [details] [diff] [review]
Fix javaScript Error: oldIcc is null, v=1
(Assignee)

Updated

6 years ago
Attachment #699139 - Flags: review?(allstars.chh)
Attachment #699139 - Flags: review?(allstars.chh) → review+
Should this be uplifted to the b2g18 branch? If so, please nominate...
(In reply to Johnny Stenback (:jst, jst@mozilla.com) from comment #3)
> Should this be uplifted to the b2g18 branch? If so, please nominate...

No, this bug is caused by patches check-in in these few days, Bug 821999.
https://hg.mozilla.org/mozilla-central/rev/97a765a54526
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
You need to log in before you can comment on or make changes to this bug.