Closed Bug 827801 Opened 7 years ago Closed 7 years ago

[OS.File] Test that OS.Constants is not defined in content

Categories

(Toolkit :: OS.File, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED WONTFIX
mozilla21

People

(Reporter: Yoric, Assigned: Yoric)

References

Details

(Whiteboard: [mentor=Yoric][lang=js])

Attachments

(1 file)

To avoid regressions, we should add a test to ensure that non-privileged web workers do not have access to OS.Constants.
Assignee: nobody → dteller
Attachment #699842 - Flags: review?(khuey)
I landed a test that covers this as part of bug 827193.
https://hg.mozilla.org/mozilla-central/rev/8d16c92e1bf4
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Fun fact: we don't run tests starting with "test-" instead of "test_".
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Ms2ger: Gasp. How comes there are a few dozens of these on m-c?

Well, anyway, since gavin has landed something already, I guess we should revert that patch and mark the bug as WONTFIX.
(In reply to David Rajchenbach Teller [:Yoric] from comment #6)
> Ms2ger: Gasp. How comes there are a few dozens of these on m-c?

These are either reftests or resources for other tests to use.
Reverted, as this test is 1/ not executed 2/ not useful.

https://hg.mozilla.org/integration/mozilla-inbound/rev/bf0d25a344fb
Backout of the makefile changes too:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a200bde12057

This bug now wontfix?
Indeed
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.