Analytics report events not supported by privacy policy

RESOLVED FIXED

Status

Firefox OS
Gaia::Everything.me
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Evyatar 'Tron' Amitay (everything.me), Assigned: ranbena)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(b2g18 fixed)

Details

Attachments

(1 attachment)

Missing requestId to pass to analytics. Plus keep only the following events (everything else isn't supported by privacy policy):

Search pageView, App click, Load more, Add to home screen

Comment 1

5 years ago
To expand on Evyatar's description, we're minimizing the amount of client-side events collected for learning and improvement purposes to the minimal amount possible as discussed and agreed with the privacy / legal team and we've also went ahead and limited analytics reporting only to users that have opted-in on sharing usage data during FTE
Created attachment 700756 [details]
Fixed analytics events

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #700756 - Flags: review?(crdlc)
Attachment #700756 - Flags: approval-gaia-master?(21)
(Assignee)

Updated

5 years ago
Assignee: evyatar → ran
(Assignee)

Updated

5 years ago
blocking-basecamp: --- → ?
Comment on attachment 700756 [details]
Fixed analytics events

Great, works and less libraries!
Attachment #700756 - Flags: review?(crdlc) → review+
(Assignee)

Updated

5 years ago
blocking-basecamp: ? → ---
Comment on attachment 700756 [details]
Fixed analytics events

Starting from now I will redirect E.me PR's approval to Francisco :)
Attachment #700756 - Flags: approval-gaia-master?(21) → approval-gaia-master?(francisco.jordano)
You will be missed :)
Comment on attachment 700756 [details]
Fixed analytics events

Tried on the phone (couldn't check any unit test). Looking good to me, will help to improve the performance of e.me

Thanks for the hard work, and sorry for taking that much time reviewing.
Attachment #700756 - Flags: approval-gaia-master?(francisco.jordano) → approval-gaia-master+
Merged!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
please ran, add the hash commit in a comment next time, thanks

https://github.com/mozilla-b2g/gaia/commit/bb015b4cd6a09583e332dd8f51c38850b0d799e9
No prob
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.