Can't add blank priority to existing bugzilla installation

VERIFIED WORKSFORME

Status

()

Bugzilla
Bugzilla-General
VERIFIED WORKSFORME
17 years ago
5 years ago

People

(Reporter: Stephen Rasku, Assigned: justdave)

Tracking

Details

(Reporter)

Description

17 years ago
The fix for bug 49862 allows the default of a blank priority for new bugs. 
However, you can't add this to an existing Bugzilla installations.  I tried to
change the defaultpriority from "P3" to "--" in editparams.cgi.  However, when I
try and do this, I get:

	New value for defaultpriority is invalid: Must be a legal priority 
	value: one of P1, P2, P3, P4, P5
you have to add "--" as a legal priority on your installation first.

This is done in the localconfig file.  Once you change localconfig, you need to 
run checksetup.pl for the changes to take effect.  Then you can get back into 
editparams.cgi and it will allow you to set the defaultpriority to --.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

17 years ago
OK, this works.  

As an aside, it changed a bunch of permissions on my scripts so that it
temporarily broke my installation.  Is this a known issue?
Status: RESOLVED → VERIFIED
is it stuff you added yourself?

it sets permissions to operate how it needs to as installed.  Anything it doesn't 
know about gets set to 640.  There's a subroutine in checksetup.pl that 
determines whether a file is executable or not.  if you've added your own stuff 
you'd need to add the filenames to the list in that routine.
(Reporter)

Comment 4

17 years ago
I see what the problem is.  Our Bugzilla files are maintained via CVS.  If a
developer checks a file, then that file will end up being owned by the
developer.  I fixed this by giving o+rx permissions but since checksetup.pl
doesn't preserve the world permissions it causes the problem I saw.
We do that on our site, too, however, the auto-checkout/update script that runs 
after someone checks in code is setuid to the user the code has to run under.  
Doing it this way also prevents the developers from mucking with the production 
code without going through cvs first, since the permissions can be set such that 
they can't write to it directly.
(Reporter)

Comment 6

17 years ago
I am using cvs loginfo to update the web-site.  Is that what your using?  How do
you make it setuid?
I have a small C program I wrote that forks off and immediately returns to the 
calling loginfo script.  After forking off, it does a cd into the destination 
directory and does a cvs update.  I have the program setuid and setgid to the 
user the code runs under.  It has to fork off because the cvs locks don't get 
cleared until the commit action exits, which won't happen until the loginfo 
scripts complete.
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Assignee: tara → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: Bugzilla 2.12 → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.