[camera] shutter sound is almost inaudible

RESOLVED DUPLICATE of bug 822773

Status

()

Core
General
RESOLVED DUPLICATE of bug 822773
5 years ago
5 years ago

People

(Reporter: marcia, Assigned: rlin)

Tracking

({regression, unagi})

18 Branch
ARM
Gonk (Firefox OS)
regression, unagi
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
unagi, seen while running:

Gecko: fcf2a2a59ec0
Gaia: fbe74c8441c3

STR:
1. Open the camera app and take a picture
2. Observe the shutter sound, which is almost inaudible

I spoke with Tony on IRC and he suggested filing a bug. I have noticed this behavior for some time. I remember at one point during testing the sound was a bit louder than it is now.

Will attach a screencast in a moment, although I am not sure that will show the issue as well as it does in person.

Comment 1

5 years ago
nom'ing for bb? because i believe the shutter sound needs to be at a certain audible volume for privacy reasons.   marcia's screencast will show its barely a whisper.

Comment 2

5 years ago
Also, regression keyword.  this used to sound just fine at a reasonable volume.  is there a industry standard for the shutter volume?
Keywords: regression
We're probably simply using the "normal" channel which is quite hard to adjust the volume of.

In any case, this doesn't seem like a blocker.
blocking-basecamp: ? → -
As I know, device sold on Japan/Koren must force the shutter sound to be audiable and can't be muted,  I think this can be customized by partner by changed the shutting sound to use thepublicnotification audio channel.

Comment 5

5 years ago
The shutter sound from gaia/apps/camera/js/camera.js already used publicnotification channel. Also it is initialized with max volume in Gecko. It is wired to have small sound.
So our design won't let user to disable the shutter sound?

Comment 7

5 years ago
We can disable it from setting App.
Created attachment 699541 [details] [diff] [review]
patch 1

force publicnotification audio channel output at maximal volume.
Assignee: nobody → rlin
Created attachment 699542 [details] [diff] [review]
patch 2
Attachment #699541 - Attachment is obsolete: true
I'm concerned about us -'ing this. I tested with Marcia beside me, and I heard no sound whatsoever. I have no idea what channel it's on, but that's probably not great.
Status: NEW → RESOLVED
blocking-basecamp: - → ?
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 822773
(In reply to Randy Lin [:rlin] from comment #4)
> As I know, device sold on Japan/Koren must force the shutter sound to be
> audiable and can't be muted

I can't find much online to back this up.

http://android.stackexchange.com/questions/32442/jurisdictions-where-camera-shutter-sound-is-mandated-by-law
blocking-basecamp: ? → ---

Comment 13

5 years ago
The link as below shows that someone introduced this bill in Congress of NY and that refer from Korea and Japan.

http://www.tomsguide.com/us/Camera-phones-noise-photo-Congress,news-3371.html

The link as below is the summary of bill.

http://thomas.loc.gov/cgi-bin/bdquery/z?d111:HR00414:@@@L&summ2=m&
Comment on attachment 699542 [details] [diff] [review]
patch 2

[Triage Comment]
Attachment #699542 - Flags: approval-mozilla-b2g18+
You need to log in before you can comment on or make changes to this bug.