invisible autocomplete widget eats clicks

RESOLVED DUPLICATE of bug 66834

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 66834
17 years ago
9 years ago

People

(Reporter: saari (gone), Assigned: David Hyatt)

Tracking

Trunk
mozilla1.1alpha
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
It looks like there is an invisible auto complete widget that is eating a click 
to roll it up.

1) open 2 windows
2) type in the url bar on one window, do not press enter.
3) click on the other window. nothing happens
4) click again on the other window, this time, the window comes forward

Looks like there maybe be an invisible autocomplete widget eating that first 
click. This should be 0.9.1

Comment 1

17 years ago
This is a bug I keep forgetting to file.  While working on autocomplete I was
constantly running into the problem of the autocomplete popup refusing the paint
itself under certain conditions.  Primarily, it won't paint itself when there
are no matches for 2 consecutive keystrokes.

This seems to be due to the contained outliner not having any new paint events
on itself.  There are some commented out dumps in autocomplete.xml to make sure
that I'm actually telling the popup to open.  It does THINK that it is open, but
it just doesn't paint.

Giving to pinkerton as a first guess for who might own this.
Assignee: hewitt → pinkerton
Component: Themes → XP Toolkit/Widgets: Menus
Summary: invisible autocomplete widget eats clicks → autocomplete popup won't paint sometimes

Comment 2

17 years ago
This sounds like two different bugs, please file a separate bug for the paint
problem.  Reverting summary to original description, ->1.0
Summary: autocomplete popup won't paint sometimes → invisible autocomplete widget eats clicks
Target Milestone: --- → mozilla1.0

Comment 3

17 years ago
are bug 83362 and bug 84932 dups of this?

Comment 4

17 years ago
This might be a duplicate of bug 66834, "location bar drop-down should not block
clicks outside of itself".

Updated

16 years ago
Keywords: oeone
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0 → mozilla0.9.9
Target Milestone: mozilla0.9.9 → mozilla0.9.7
not going to get to it. --> toolkit
Assignee: pinkerton → hyatt
Status: ASSIGNED → NEW
QA Contact: pmac → jrgm
Target Milestone: mozilla0.9.7 → ---
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1

Comment 6

16 years ago
Nominating for mozilla1.0. This bug results in a usability issue in Penzilla
that would ideally be corrected by 1.0.
Keywords: mozilla1.0

Comment 7

15 years ago
Nothing has happened to move this bug along in a long time, but it is still
causing usability issues, in Mozilla as well as for OEone.

Also, the OS is wrong as this is definitely not only happening in Windows 2000.

Comment 8

15 years ago
I don't get an invisible autocomplete widget when I type in the URL bar anymore,
because I always get at least "Search for .." as one option in the autocomplete.

Anyway, this bug is really a dup of bug 66834.

*** This bug has been marked as a duplicate of 66834 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.