[B2G][Contact] Facebook: Linking Facebook contact does not change the Name and Surname of the contact.

VERIFIED INVALID

Status

Firefox OS
Gaia::Contacts
VERIFIED INVALID
5 years ago
5 years ago

People

(Reporter: Darren, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: testrun 2)

(Reporter)

Description

5 years ago
Repro Steps:
1. Load the Unagi build 20130104070203.
2. Create a contact with a first and last name.
3. Link the contact to an Facebook contact that has both a first and last name.

Actual Results:
The Facebook contact is linked, but the name still displays the original name.

Expected Results:
The contact linked to the Facebook will display the Facebook contact's first and last name, until unlinked.

Notes:
When the contact only has a first name and is linked to a Facebook contact with both, the last name displays the Facebook contact's last name.

Repro Rate:
3/3 on 1 device

Comment 1

5 years ago
this is not a bug. In Facebook link functionality the local information takes precedence over Facebook information.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Comment 2

5 years ago
UCID: owd-13749 

Link: https://moztrap.mozilla.org/results/case/63768/

Test Case: #5270
Whiteboard: testrun 2

Updated

5 years ago
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM
(Reporter)

Comment 3

5 years ago
Verified as invalid, proper functionality is that local data is not replaced by imported data.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.