[B2G][Clock]Edit Mode: X icon for cancel edit not shown it show the back < arrow.

VERIFIED FIXED

Status

Firefox OS
Gaia::Clock
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Misty Byrd, Assigned: ivanovpavel)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 fixed)

Details

(Whiteboard: visual design, BerlinWW, UX-P4, testrun 2, landed in uxbranch, qa-verified)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 699334 [details]
screen shot for edit alarm icon

Issue: When selecting an existing alarm to edit, the top left icon shows as a < back icon not X to cancel edit 

 Steps to Reproduce:

1) Install Build 20130104070203 v.1 on a Unagi Device
 2) Select Clock app
3) Select + in upper right hand corner (to add new alarm)

 4) Select a time and label for new alarm

 5) Select done (alarm is added to alarm page)

 6) Select alarm that was just added to open in edit mode

7.) Make changes to existing alarm

8.) Look to top left to cancel changes


Expected: Per test case #2052  alarm settings and press "X" button on the top-left corner to cancel changes

Actual:
Icon on the top-left corner is < back arrow to cancel changes

Notes:
Repro frequency:
Repros 10/10 times, checked on different devices
Included screen shot. This could be a test case edit.
The style of the back button is a building block of header section.

Josh,
Is it an issue?
Or, the test case is needed to update.
Thanks.
Flags: needinfo?(jcarpenter)
Hi Ian, Misty is right: if you have time, we should change the "<" to and "x" instead.
Flags: needinfo?(jcarpenter)
Whiteboard: visual design, BerlinWW, UX-P4
Assignee: nobody → pivanov
Whiteboard: visual design, BerlinWW, UX-P4 → visual design, BerlinWW, UX-P4, landed in uxbranch
Whiteboard: visual design, BerlinWW, UX-P4, landed in uxbranch → visual design, BerlinWW, UX-P4
I see Pavel has taken the issue.
Thanks.
Created attachment 700345 [details]
patch for UX branch
Created attachment 700346 [details]
patch for Gaia repo

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #700346 - Flags: review?(kaze)
Attachment #700346 - Flags: review?(jcarpenter)
Attachment #700346 - Flags: approval-gaia-master?(21)
Attachment #700346 - Flags: review?(jcarpenter) → review+
Attachment #700346 - Flags: review?(kaze) → review+
Comment on attachment 700346 [details]
patch for Gaia repo

Basically just switching CSS styles, very low risk for UX gain. approval-gaia-master+
Attachment #700346 - Flags: approval-gaia-master?(21) → approval-gaia-master+

Comment 7

5 years ago
UCID: clock-004
https://moztrap.mozilla.org/results/case/61317/
Whiteboard: visual design, BerlinWW, UX-P4 → visual design, BerlinWW, UX-P4, testrun 2

Comment 8

5 years ago
Landed in UX Branch https://github.com/gordonbrander/gaia/commit/76931c135fca26b7a1b8edd8031cfc435b643091
Whiteboard: visual design, BerlinWW, UX-P4, testrun 2 → visual design, BerlinWW, UX-P4, testrun 2, landed in uxbranch

Comment 9

5 years ago
defects still reproduces on the Unagi device Build ID: 20130115070201   using the dec 5th kernel
yes, ahubenya, you will still see this issue in the main branch; this is a uxbranch fix.

Question : are all cancel items suppose to have x instead of < ?
Whiteboard: visual design, BerlinWW, UX-P4, testrun 2, landed in uxbranch → visual design, BerlinWW, UX-P4, testrun 2, landed in uxbranch, qa-verified
(In reply to Naoki Hirata :nhirata from comment #10)
> Question : are all cancel items suppose to have x instead of < ?

If there’s an action button (“Done”, “Save”, etc.) in the top-right corner then it’s a dialog. If it’s a dialog, the cancel button should be an "x", not a "<".

Updated

5 years ago
Hardware: x86_64 → ARM

Updated

5 years ago
OS: Windows 7 → Gonk (Firefox OS)

Updated

5 years ago
QA Contact: jshih → fyen
Gaia:     6c53dfd2e5d60393f6a57e9e1a4b5af6a3d6a783
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/2226f181c8c2
BuildID   20130126070202
Version   18.0

Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.