typo in contact_details.js, combines expressions with single ampersand

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: freddyb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Curent master, contact_details.js line 168+ it says:

    return contact != null & contact.category != null &&
              contact.category.indexOf('favorite') != -1;

where it should say


    return contact != null && contact.category != null &&
              contact.category.indexOf('favorite') != -1;

Comment 1

6 years ago
Created attachment 699806 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7440

Pointer to Github pull-request

Comment 2

6 years ago
Comment on attachment 699806 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7440

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #699806 - Flags: review?(francisco.jordano)
Attachment #699806 - Flags: approval-gaia-master?(francisco.jordano)
Comment on attachment 699806 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7440

non risky change

a=me
Attachment #699806 - Flags: review?(francisco.jordano)
Attachment #699806 - Flags: review+
Attachment #699806 - Flags: approval-gaia-master?(francisco.jordano)
Attachment #699806 - Flags: approval-gaia-master+

Comment 5

6 years ago
Thanks :freddyb for pointing out this!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.