[b2g] [Everything.me] When no Internet/Data connection is available, tapping the +More button in Everything.me results in Infinite Loading page.

VERIFIED DUPLICATE of bug 826198

Status

Firefox OS
Gaia::Everything.me
VERIFIED DUPLICATE of bug 826198
5 years ago
5 years ago

People

(Reporter: croesch, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 699371 [details]
Everything.me with no connection available.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

1. Launch Unagi build 20130104070203 Version 18.0
2. Turn your Wifi and Data connections OFF.
3. Navigate to the Everything.me page.
4. You will see the categories and you will also see the +More button.
5. If you tap the +More button, you will be taken to a page that will show a Loading page with a spinning cursor that will attempt to load forever.
6. Fortunately there is also a Cancel button but this does not seem to be the desired behavior if your device is offline.

Repro 5/5 on multiple devices.


Actual results:

With no internet/data connection, when you tap the +More button in Everything.me, you will see that instead of getting a message stating that there is no internet connection to perform this action, Instead you will get a Loading screen that attempts to load infinitely.


Expected results:

I would expect as an end user I would get an explanation on what the problem is instead of seeing a promising message that will never get fulfilled.
(Reporter)

Comment 1

5 years ago
Before writing this bug I took a hard look at all the Everything.me bugs regarding the Offline handling but did not specifically see this issue discussed.

The closest possibly related bug would be
Offline Behavior Isn't Correct.
https://bugzilla.mozilla.org/show_bug.cgi?id=824352

However this person mentions the previous screen to mine and a message that I think should be shown on the +More screen when doing my steps.

Doing what I can to avoid the dreaded Dupe ;)
(Reporter)

Updated

5 years ago
Component: General → Gaia::Everything.me
So sorry but it's a DUPE! :)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 826198

Updated

5 years ago
OS: All → Gonk (Firefox OS)
Hardware: All → ARM

Comment 3

5 years ago
This issue no longer repros and is dupe correctly.  Now when selecting more notification comes up that says 'Connect to the internet to add more shortcuts'.  This is on Build ID 20130211070202 Dec 5th build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.