"mobile" and "android" overlayed on amo

VERIFIED FIXED in 2013-03-28

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: blassey, Assigned: cvan)

Tracking

unspecified
2013-03-28
Other
Android

Details

Attachments

(2 attachments)

Created attachment 699386 [details]
screenshot
Duplicate of this bug: 829781

Updated

5 years ago
Duplicate of this bug: 831110
Tracking for investigation?
tracking-fennec: --- → ?
(Reporter)

Updated

5 years ago
tracking-fennec: ? → 20+
We're driving people to AMO for theme support in 19, so we'd like to make sure this is resolved before that goes to release.
tracking-fennec: 20+ → 19+
tracking-firefox19: --- → ?
Component: General → Public Pages
Product: Firefox for Android → addons.mozilla.org
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 829269

Updated

5 years ago
tracking-firefox19: ? → -

Comment 6

5 years ago
This problem still exist.  I am not sure it is a dup of the other one. 

This is a pretty serious UI issue - it is basically the first thing I see when I want to install an add-on.
Assignee: nobody → mark.finkle
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: mark.finkle → nobody
19 has already shipped, renominating for tracking
tracking-fennec: 19+ → ?
Chris - we still this happening during page load, which can take a few seconds. Is there something we can do to make the layout happen faster? 

It looks bad since AMO is really the front-door for add-ons in Fennec.
tracking-fennec: ? → +
(Assignee)

Comment 9

5 years ago
Previously there was a FOUC that was attributed to a Fennec bug (bug 759678). We're now inlining all of our CSS in a <style> as part of bug 721523. We tried reverting it but we noticed another visual bug (not sure if it's related to the original Fennec bugs, but was not reproducible on stock browser). So we're back to the inline <style>. There are not even HTTP requests for our CSS at all now and data URIs for most icons - we're pulling in just a few images for add-on icons/previews.

That aside, sure thing - let me look into into seeing what we can do with the header text. That's not really acceptable on our end.
Assignee: nobody → cvan
Target Milestone: --- → 2013-03-21
(Assignee)

Comment 10

5 years ago
https://github.com/mozilla/zamboni/commit/b4c56ec

Mark, the overlapping text was from the `alt` attribute text on the `<img>`. There must've been a CDN issue when resolving that image. I've removed the `alt` text and changed the heading to say "Add-ons" instead of "Mobile Add-ons" so there's no wrapping.

Thanks for your bringing it to our attention - and let me know if there's anything else! (This will go live in about an hour with our weekly push.)
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
I still see the overlapping text on-load for a second, it resolves but it's still visible.

Comment 12

5 years ago
Created attachment 730406 [details]
screenshot

I can reproduce this issue on -dev and prod.
(Assignee)

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: 2013-03-21 → 2013-03-28
(Assignee)

Updated

5 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 13

5 years ago
Aaron, Krupa - thanks. The original screenshot showed just the detail page; I forgot we show the same logo with `alt` text ont homepage as well. I've fixed it there as well now! This is on -dev and will go to prod later today.

https://github.com/mozilla/zamboni/commit/8a5593c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Comment 14

5 years ago
It looks better now. But can we have the logo next to the header please?

Comment 15

5 years ago
(In reply to krupa raj 82[:krupa] from comment #14)
> It looks better now. But can we have the logo next to the header please?

Cvan fixed this. Thanks!
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.