Settings app overwrites WifiManager events

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mrbkap, Assigned: mrbkap)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(blocking-basecamp:-, b2g18+ fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
connectivity.js and wifi.js both set the WifiManager event handlers. They should play more nicely together.
(Assignee)

Comment 1

5 years ago
This causes (at least) the wifi panel to break when we change the language in the settings app (though closing and reopening the settings app fixes it).
blocking-basecamp: --- → ?
(Assignee)

Comment 2

5 years ago
Pull request: https://github.com/mozilla-b2g/gaia/pull/7424
Assignee: nobody → mrbkap
Flags: needinfo?(kaze)
lgtm
Flags: needinfo?(kaze)
blocking-basecamp: ? → -
tracking-b2g18: --- → +
We would take a patch for this
(Assignee)

Comment 5

5 years ago
Created attachment 699847 [details]
pull request

This basically has review already (see comment 3) and simply needs the stamps to land.
Attachment #699847 - Flags: review?(kaze)
Attachment #699847 - Flags: approval-mozilla-b2g18?
Comment on attachment 699847 [details]
pull request

Nice work, thanks Blake.

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined:
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #699847 - Flags: review?(kaze)
Attachment #699847 - Flags: review+
Attachment #699847 - Flags: approval-gaia-master?(21)
Attachment #699847 - Flags: approval-mozilla-b2g18?
Attachment #699847 - Flags: approval-gaia-master?(21)
Attachment #699847 - Flags: approval-gaia-master+
https://github.com/mozilla-b2g/gaia/commit/914a7d15b86f96892b2da2ff3edecbac1dc2976b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.