The security notification (security lock) is not displayed on first page load

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: AdrianT, Unassigned)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox19 affected, firefox20 affected, firefox21 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 699637 [details]
logs

Firefox Mobile 19 beta 1 / Nightly 21.0a1 2013-01-04
Samsung Galaxy Tab 2 7.0 (Android 4.0.4)

Steps to reproduce:
1) Go to store.steampowered.com - the desktop version
2) Tap on the login link and wait for the Login page to load
3) The page loads and displays the security notification
4) Reload the page and recheck the security notification

Expected results:
Both at steps 3 and 4 the security notification is displayed

Actual results:
The first time the page is loaded the security notification is not displayed. The security notification is displayed only the second time the website is loaded
Attachment #699637 - Attachment mime type: text/x-log → text/plain
Keywords: qawanted
We should use the remote web console to check if the page has any http:// resources which would break the page security, thus we would not show the lock icon.
I can reproduce this on mozilla-beta, but this seems fixed on nightly/aurora.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 3

6 years ago
I am able to reproduce the issue on the latest Nightly and Aurora builds if I make clean profiles for every Firefox instance I have installed. If I load the page once on any of the installed builds, I don't get the security larry on first load, but loading the page on any other build after that displays the security larry.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Works for me on Nightly/Aurora. My guess is we're seeing different dynamic content at different times and that this is working as expected.
(Reporter)

Updated

6 years ago
QA Contact: adrian.tamas
need info to Aaron to get on the same page as Andreea
Flags: needinfo?(aaron.train)
(Reporter)

Comment 7

6 years ago
Created attachment 724297 [details]
remote webconsole output
As I suspected there are http:// elements being loaded. Does the log include reloading the page as listed in the str?
Flags: needinfo?(aaron.train)
(Reporter)

Comment 9

6 years ago
The log just contained loading the page once not reload. I tried to reproduce today on both Nightly 22.0a1 2013-03-13 and Firefox Mobile 20 Beta 5 build 1 and I can't reproduce the issue anymore. They may have changed something from the page. Closing this issue as WFM. Will reopen and add complete webconsole logs if I can reproduce this again
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

6 years ago
Keywords: qawanted
(Assignee)

Updated

5 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.