[Bluetooth]HFP PTS TC_AG_SDP_BV_01_I test case fail

RESOLVED INVALID

Status

Firefox OS
General
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: shawnjohnjr, Assigned: shawnjohnjr)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

SDP_BV_01_I.
To verify that the IUT can respond to Service Search requests in various conditions.
-Before pairing
-After pairing
-After SLC connection
-After a call is made active with audio routed to the HF.
	- MTC: Service discovery is successful before pairing.
	- AT: SPP connect succeeded
	- AT: Service Level Connection established
	- AT: post SLC command sequence complete
	- AT: Service Level Connection disabled
	- MTC: IUT is paired with PTS.
	- MTC: Service discovery is successful after pairing.
	- FATAL ERROR (AT): Error in SPP connect response
	- MTC received unexpected EXIT message from AT component
	- MTC: Test case ended
Assignee: nobody → shuang
From the trace, it looks like SPP connection dropped from phone. We need to check into detail why connection was been ignored.
Blocks: 829396
I suspect the root cause is we try to CloseSocket whenever we have an another new Handsfree SLC handshake. When there is an incoming connection, we dropped it. Need to review connection management for HFP.
Invest this issue in detail. Check with test case log from HF side.
It caused by the timing of SPP connection request from HF side.
It's not related to CloseSocket. But it's like SPP request sent from HF side but pairing not yet finished. So AG side reject SPP connection.

+35490 ms
Receive event:           :[164]SPP?SPP_CONNECT_CFM=PDU:{
                           bd_addr:'48282FF9B466'O,
                           channel:'0A'O,
                           dlci:'14'O,
                           framesize:666,
                           accept:GcFALSE,
                           result:RFCOMM_ESTABLISH_DENIED_SECURITY_e
                         }
Created attachment 702742 [details]
Explain why this test case failed
Created attachment 702745 [details]
Hcidump from unagi
Created attachment 702747 [details]
hcidump snoop log
This issue was caused by temporary link key. Due to temporary link key only temporary stored. After connection session eneded, which cause PTS error due to Negative Link key reply response (Key Missing).
Found issue was caused by PTS test tool "Deleted" link key option which cause problem. It's not device issue. Make Link key option (PIXIT) TSPX_delete_link_key = FALSE. This test case can pass.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.