Allow to modify explicit permissions for certified apps

VERIFIED FIXED in B2G C4 (2jan on)

Status

Firefox OS
Gaia::Settings
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: gwagner, Assigned: baku)

Tracking

unspecified
B2G C4 (2jan on)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
We let the user decide if the camera app or E.me can use geolocation. If the user decides to remember the permission we have to be able to change it in settings->permissions.
(Reporter)

Updated

5 years ago
blocking-basecamp: --- → ?
(Reporter)

Updated

5 years ago
Summary: Allow to modify geolocation permission for certified apps → Allow to modify explicit permissions for certified apps
(Reporter)

Updated

5 years ago
Assignee: nobody → amarchesini

Updated

5 years ago
Duplicate of this bug: 828215
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Comment 3

5 years ago
Created attachment 699744 [details] [diff] [review]
patch

We don't want to show any apps, but only certified apps with some explicit permission set. So at start-time this patch creates an array of explicit permissions and then it uses this list for checking any certified app.
Attachment #699744 - Flags: review?(etienne)
Comment on attachment 699744 [details] [diff] [review]
patch

Review of attachment 699744 [details] [diff] [review]:
-----------------------------------------------------------------

::: apps/settings/js/apps.js
@@ +48,5 @@
> +    var table = this._permissionsTable;
> +    table.explicitCertifiedPermissions = [];
> +
> +    var mozPerms = navigator.mozPermissionSettings;
> +

As we talked about: probably good to add a small comment here explaining that we need _any_ certified app in order to build the explicitCertifiedPermissions list so we use the Settings app itself.
Attachment #699744 - Flags: review?(etienne) → review+
(Assignee)

Comment 5

5 years ago
Created attachment 699818 [details] [diff] [review]
patch b

HiddenApps added
Attachment #699744 - Attachment is obsolete: true
Attachment #699818 - Flags: review?(etienne)
Attachment #699818 - Flags: review?(etienne) → review+
Merged... though, I just realized that wasn't a bb+ bug. Feel free to backout. If it doesn't get approved not bb+.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Ask for approval please, not a V1 Blocker.
blocking-basecamp: ? → -
Lucas, can you chime in here with necessity of making these app's permissions editable from Settings for v1, and renom if you think we can't live without this?
Flags: needinfo?(ladamski)
(In reply to David Scravaglieri [:scravag] from comment #8)
> Ask for approval please, not a V1 Blocker.

Umm. No. Factory reset isn't an acceptable work-around.
blocking-basecamp: - → ?
(In reply to Jason Smith [:jsmith] from comment #10)
> (In reply to David Scravaglieri [:scravag] from comment #8)
> > Ask for approval please, not a V1 Blocker.
> 
> Umm. No. Factory reset isn't an acceptable work-around.

If someone manages to select deny for camera they are permanently prevented from ever re-enabling permissions. That's a foot gun we can't ship with.
Actually I won't bother renoming since it's already fixed.
blocking-basecamp: ? → ---
Flags: needinfo?(ladamski)
For the record, I do think this was a blocker.
blocking-basecamp: --- → +

Updated

5 years ago
Keywords: verifyme
QA Contact: jsmith
Target Milestone: --- → B2G C4 (2jan on)
Looks okay for the camera app. Strangely enough, I don't any apps listed that are not launchable items from the homescreen itself that call out for geolocation. Specifically:

- Homescreen
- System

Browser is showing up as well, although I find it a tad bit awkward why it needs geolocation.

I'll file followups for the browser question & the homescreen/system apps not showing up on user builds. Verified.
Status: RESOLVED → VERIFIED
Keywords: verifyme

Updated

5 years ago
Depends on: 830659
You need to log in before you can comment on or make changes to this bug.