[Dialer] Call logs doesn't show nothing

VERIFIED FIXED in B2G C4 (2jan on)

Status

P2
critical
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: dscravaglieri, Assigned: gtorodelvalle)

Tracking

({regression})

unspecified
B2G C4 (2jan on)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
gaia: a069d55133b78be543314af0c61f79cc80446c93
gecko: ebec08e6c3de

STR:
1 - Call a phone from Firefox OS
2 - Answer a call in Firefox OS
3 - Miss a call in Firefox OS
4 - Open Call Log

Expected:
See the call log filled with the received/made and miss call

Actual:
The list is empty
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?
(Reporter)

Updated

6 years ago
Assignee: nobody → gfs07
Assignee: gfs07 → gtorodelvalle
Hi guys, the problem is in the lazy_l10n.js file and more concretely with the _waitForLoad function. Although the localized event is fired and handled, navigator.mozL10n is undefined in this handler :-O Currently investigating it ;) Thanks!
reproduced on 20130109071737 build.  call log incoming and outgoing shows blank stuff
Severity: normal → critical
Keywords: regression
Created attachment 699836 [details] [diff] [review]
Associated PR.

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #699836 - Flags: review?(alberto.pastor)
Attachment #699836 - Flags: approval-gaia-master?(francisco.jordano)
I included Francisco as approval-gaia-master although this bug is a clear candidate for bb+ ;-)
(Reporter)

Updated

6 years ago
blocking-basecamp: ? → +
Priority: -- → P2
Target Milestone: --- → B2G C4 (2jan on)
Comment on attachment 699836 [details] [diff] [review]
Associated PR.

bb+ now :)
Attachment #699836 - Flags: approval-gaia-master?(francisco.jordano)

Updated

6 years ago
Attachment #699836 - Flags: review?(alberto.pastor) → review+
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 828566
gtorodelvalle@gmail.com, please reference the changeset of the landed patch. Thans a lot.
Duplicate of this bug: 828716
Sorry guys! and thanks to Francisco ;)
Duplicate of this bug: 828847

Comment 12

6 years ago
verified on the unagi, Build id:20130113070202
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.