The Power saving icon ($ image) is not clear its for saving power

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: tchung, Assigned: alive)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: visual design, BerlinWW, UX-P2)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Created attachment 699747 [details]
screenshot

The new power saving icon that is in the 20130109071737 build is not truly representing what a user might think it does.    At first glance, i thought it is the Cost Control app, which will tell me how much $ on data/voicecalls/texts i spent.   I was a little surprised to discover it turns off all my wifi, data, and Bluetooth services.  Only after digging around more, did i figure it was a power saving feature.

IMO, the icon does not represent power saving, and instead alludes me to think i should see how much $ i'm spending.  Asking for this to be removed, and bring back the leaf, if needed.

Screenshot.

Repro:
1) install 20130109071737 nightly unagi build
2) pull down the notification bar
3) Verify $ on rectangle icon.
Since power savings does not function as initially spec'd, we've decided make it work just like airplane mode. Please add the airplane mode functionality to that toggle and replace it with the icons attached.
Assignee: nobody → alive
See Also: → bug 828320
Summary: The Power saving icon ($ image) is not clear its for saving power → Power S
Created attachment 699817 [details]
Airplane Mode Icons
Whiteboard: BerlinWW → visual design, BerlinWW, UX-P2
(In reply to Patryk Adamczyk [:patryk] UX from comment #1)
> Since power savings does not function as initially spec'd, we've decided
> make it work just like airplane mode. Please add the airplane mode
> functionality to that toggle and replace it with the icons attached.

Do we need to remove the power-saving function in settings app?
Flags: needinfo?(padamczyk)
Please leave that as is. The main reason we're changing it in the notifications center is that its ambiguous currently, no one really knows what it does as it wasn't implemented correctly. We'll likely want to reside how that toolbar functions in a near future version.
Flags: needinfo?(padamczyk)
Summary: Power S → The Power saving icon ($ image) is not clear its for saving power
Created attachment 699912 [details]
Airplane Mode Icons

Made, a slight update = optimized their size.
Attachment #699817 - Attachment is obsolete: true
Created attachment 700702 [details]
https://github.com/mozilla-b2g/gaia/pull/7532

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #700702 - Flags: review?(timdream+bugs)
Attachment #700702 - Flags: approval-gaia-master?(21)
Comment on attachment 700702 [details]
https://github.com/mozilla-b2g/gaia/pull/7532

a=me. It seems like you also forgot to remove the power-save images in the PR.
Attachment #700702 - Flags: approval-gaia-master?(21) → approval-gaia-master+
Attachment #700702 - Flags: review?(timdream+bugs) → review+
https://github.com/mozilla-b2g/gaia/pull/7532
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.