Daylight savings time (DST) is being calculated incorrectly to always use the USA DST date, but really should use the timezone's DST date

RESOLVED INVALID

Status

Firefox OS
Gaia::Calendar
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Saw this with my own calendar against the timezone specified. We aren't calculating Daylight Savings Time (DST) dates correctly on a per locale basis. As a result, certain locales will show events off by hour on incorrect days. Here's an example:

Prerequsite: My timezone is in Berlin, Germany.

Steps:

1. Import your calendar with events on each day in the March 2013 timeframe
2. View March 2013

Expected:

DST starting rules should only be applied after March 31st.

Actual:

DST starting rules start applying after March 10th. This implies that we applied the DST rules for United States's definition of the DST date, not Germany's DST date. So the events within the diff between March 10th and 31st will have an incorrect start and end time.
(Reporter)

Updated

5 years ago
blocking-basecamp: --- → ?
(Reporter)

Updated

5 years ago
Summary: Daylight savings time (DST) is being calculated incorrectly - it should take the locale into account → Daylight savings time (DST) is being calculated incorrectly to always the USA DST date, but really should use the timezone's DST date
(Reporter)

Updated

5 years ago
Summary: Daylight savings time (DST) is being calculated incorrectly to always the USA DST date, but really should use the timezone's DST date → Daylight savings time (DST) is being calculated incorrectly to always use the USA DST date, but really should use the timezone's DST date
(Reporter)

Comment 1

5 years ago
The impact here is that events in the difference between when DST begins and ends will be incorrect for the locale.
(Reporter)

Comment 2

5 years ago
Here's a 2013 example:

Brazil:

DST begins              DST ends

Sunday, 20 October	Sunday, 17 February

USA:

DST begins              DST ends

Sunday, March 10th      Sunday, 3 November
(Reporter)

Comment 3

5 years ago
I'm wondering if this is a dupe of bug 827816.
(Reporter)

Comment 4

5 years ago
Talked with Tim - this *might* get fixed by bug 827816, but there might be Gaia work required here. I'm going to mark this as a dependency. When that bug gets fixed, I'll retest to see if it's magically fixed or not.
Depends on: 827816
In this particular case we are doing the right thing ( we talked about this in person ) there _are_ some issues but they are in gecko and unrelated to this particular issue.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Updated

5 years ago
blocking-basecamp: ? → ---
(Reporter)

Updated

5 years ago
No longer depends on: 827816
You need to log in before you can comment on or make changes to this bug.