[Cost Control] the drop down button doesn't have enough space for the words in Portuguese

VERIFIED FIXED

Status

Firefox OS
Gaia::Cost Control
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: nhirata, Assigned: salva)

Tracking

({l12y})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed)

Details

(Whiteboard: [EU_TPE_TRIAGED])

Attachments

(2 attachments)

Created attachment 699800 [details]
screenshot

1. set device to Portuguese
2. go to Cost control
3. go to settings

Expected: drop downs fit the words
Actual: the words extends past the length of the button
Keywords: l12y

Comment 1

5 years ago
I think this is two bugs:

The dropdowns let the text overlap.

The pt-BR strings are too long. That one's a mix of "Alerta...de dados" being long, and the options being long. Reuben, Fabio, any idea if this can be easily fixed?

this would be less of a problem if we wouldn't align vertically across sections. I guess that's usually good, but in this case, it's probably more hurtful than useful.

Comment 2

5 years ago
Changed to "Uso de dados" because of menu title gives the context for "Alerta" and since it's check, shows down "Alertar ao usar", so there's no need of "Alerta" in the first string.
Duplicate of this bug: 830525
Note: we may want to increase the checkbox size... is this a Building Block issue?
See bug 828588 as well, which I believe is also a dup.

Note: Gaia triage states we will take a patch but we will not block.
blocking-b2g: --- → -
tracking-b2g18: --- → +
Whiteboard: [EU_TPE_TRIAGED]
Duplicate of this bug: 828588
Assignee: nobody → salva
Created attachment 704788 [details]
Adding clipping rules to avoid text overflow
Attachment #704788 - Flags: review?(igonzaleznicolas)
Comment on attachment 704788 [details]
Adding clipping rules to avoid text overflow

It is a cosmetic change with no risk.
Attachment #704788 - Flags: approval-gaia-master?(francisco.jordano)
Attachment #704788 - Flags: review?(igonzaleznicolas) → review+
Comment on attachment 704788 [details]
Adding clipping rules to avoid text overflow

css change, not risky a=me
Attachment #704788 - Flags: approval-gaia-master?(francisco.jordano) → approval-gaia-master+
Landed on master

https://github.com/mozilla-b2g/gaia/commit/ed6a915a367aaa1821888b0bd509fcfd15b54403
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Working fine in Gecko-cfad7c9.Gaia-6c53dfd.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 831447
You need to log in before you can comment on or make changes to this bug.