If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Attempting to pan an iframe alternately scrolls the page and the iframe.

RESOLVED FIXED in Firefox 21

Status

Firefox OS
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jdm, Assigned: schien)

Tracking

unspecified
B2G C4 (2jan on)
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

5 years ago
STR:
1. visit cbc.ca in the browser
2. find the pannable schedule on the right side of the page
3. pan partway down it, lift finger
4. pan partway down it again

Expected:
The schedule continues to pan.

Actual:
The rest of the page is panned instead. This alternating iframe/page scrolling happens regardless of pan direction.

bb? to get it on the radar; I suspect the instance of panning iframes is not very high on the mobile web, but I don't really know anything about it.

Comment 1

5 years ago
is this a duplicate of 827715?
Most likely.
Depends on: 827715
(In reply to Doug Turner (:dougt) from comment #1)
> is this a duplicate of 827715?
no, the WIP patch for 827715 doesn't help on this bug, but the root cause should be inside the APZC.
I'll take further investigation on this bug.
Assignee: nobody → schien
(Reporter)

Comment 4

5 years ago
Created attachment 699843 [details] [diff] [review]
Attempt to scroll a cross-document parent frame when no other pannable target can be found.
(Reporter)

Comment 5

5 years ago
Comment on attachment 699843 [details] [diff] [review]
Attempt to scroll a cross-document parent frame when no other pannable target can be found.

Wrong bug.
Attachment #699843 - Attachment is obsolete: true
blocking-basecamp: ? → +

Updated

5 years ago
Duplicate of this bug: 828885
The bug is in BrowserElementScrolling.js, the first touchmove event we received is always contain the same screenX and screenY as touchstart. Therefore, we'll not perform scrolling since the moving distance is too small. However, the moving distance will continue to accumulate after the change made for bug 823619 and that's why we can have a successful scrolling for the next touchstart-touchmove transaction.

So, the defect I discovered in https://bugzilla.mozilla.org/show_bug.cgi?id=823619#c106 is severe than I thought before.
(In reply to Josh Matthews [:jdm] from comment #0)
> bb? to get it on the radar; I suspect the instance of panning iframes is not
> very high on the mobile web, but I don't really know anything about it.

This affects the Firefox OS support site. I think this is something we have to fix for release. http://people.mozilla.org/~mverdi/video/sumo-scroll.webm
Sure, I'm working on a patch for this bug. :)
Created attachment 700533 [details] [diff] [review]
Bug 828367 - APZC should not perform scrolling if BES detects panning distance is too small.

If BES found the panning distance is too small to scroll, BES need to notify APZC and APZC need to keep delaying the panning procedure.
Attachment #700533 - Flags: review?(jones.chris.g)
Comment on attachment 700533 [details] [diff] [review]
Bug 828367 - APZC should not perform scrolling if BES detects panning distance is too small.

Oh no, wrong patch! :)
Attachment #700533 - Flags: review?(jones.chris.g)
Created attachment 700581 [details] [diff] [review]
Bug 828367 - APZC should not perform scrolling if BES detects panning distance is too small.
Attachment #700533 - Attachment is obsolete: true
Attachment #700581 - Flags: review?(jones.chris.g)
Comment on attachment 700581 [details] [diff] [review]
Bug 828367 - APZC should not perform scrolling if BES detects panning distance is too small.

Works great and looks correct.

The patch seems to be based on bug 827715,but I tested it on its own.  It doesn't fix bug 827715 as-is.
Attachment #700581 - Flags: review?(jones.chris.g) → review+
(In reply to Chris Jones [:cjones] [:warhammer] from comment #13)
> Comment on attachment 700581 [details] [diff] [review]
> Bug 828367 - APZC should not perform scrolling if BES detects panning
> distance is too small.
> 
> Works great and looks correct.
> 
> The patch seems to be based on bug 827715,but I tested it on its own.  It
> doesn't fix bug 827715 as-is.
This patch should be independent from bug 827715. :)
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/cae4668deecd
https://hg.mozilla.org/releases/mozilla-b2g18/rev/a4f51b077734
status-b2g18: --- → fixed
status-firefox19: --- → wontfix
status-firefox20: --- → wontfix
Keywords: checkin-needed

Comment 17

5 years ago
Landed on inbound and b2g18, so we can close this one.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 829336
https://hg.mozilla.org/mozilla-central/rev/cae4668deecd
status-firefox21: --- → fixed
Target Milestone: --- → B2G C4 (2jan on)

Updated

5 years ago
Duplicate of this bug: 828885
Blocks: 833983
You need to log in before you can comment on or make changes to this bug.