SELECT onchange fires delayed

VERIFIED DUPLICATE of bug 3322

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED DUPLICATE of bug 3322
19 years ago
19 years ago

People

(Reporter: martin.honnen, Assigned: vidur (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
The onchange handler of SELECT element fires only when the element is clicked on
a second time e.g.

<LABEL ID="godLabel" FOR="god">
God:
</LABEL>
<INPUT TYPE="text" NAME="god">
<SELECT NAME="aSelect"
        onchange="alert(event.type);
document.getElementById('godLabel').firstChild.nodeValue =
this.options[this.selectedIndex].value + ': ';"
>
<OPTION VALUE="Kibo">Kibo
<OPTION VALUE="Xibo">Xibo
<OPTION VALUE="Maho">Maho
</SELECT>

does not fire when I select a new option but only when I afterwards click on the
select list again.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

19 years ago
Eric, considering the number of DUPs on this bug, I think you need to move this
bug up on your priority list.

*** This bug has been marked as a duplicate of 3322 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 2

19 years ago
Duplicate of Bug# 3322. Verified.
You need to log in before you can comment on or make changes to this bug.