Closed Bug 828403 Opened 9 years ago Closed 8 years ago

fotocasa.es doesn't recognize B2G UA as mobile

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: lmandel, Assigned: adamopenweb)

References

()

Details

(Whiteboard: [uaoverride] [country-es] [serversniff] [sitewait])

fotocasa.es serves a desktop site to B2G. Bug 823364 added an UA override for this domain. The override should be removed once the domain serves mobile content to B2G. This bug tracks the evangelism for the site to recognize the B2G UA and the removal of the override at that time.
Blocks: fotocasa.es
Whiteboard: [uaoverride]
Server side user agent detection. Redirection to a different domain name. 

→ http HEAD http://www.fotocasa.es/ User-Agent:'Mozilla/5.0 (Linux; Android 4.0.4; Galaxy Nexus Build/IMM76B) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.133 Mobile Safari/535.19' 

HTTP/1.1 302 Found
Location: http://m.fotocasa.es/
Server: Microsoft-IIS/7.5
X-Powered-By: ASP.NET

On firefox for Android, the Web site proposes a splash page for downloading an Android App. you can download or pass and then access the mobile site.


→ http HEAD http://www.fotocasa.es/ User-Agent:'Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0' 

HTTP/1.1 302 Found
Location: http://m.fotocasa.es/
Server: Microsoft-IIS/7.5
X-Powered-By: ASP.NET



→ http HEAD http://www.fotocasa.es/ User-Agent:'Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0' 

HTTP/1.1 200 OK
Server: Microsoft-IIS/7.5
X-AspNetMvc-Version: 4.0
X-Powered-By: ASP.NET
Whiteboard: [uaoverride] → [uaoverride] [country-es]
Whiteboard: [uaoverride] [country-es] → [uaoverride] [country-es] [serversniff]
Assignee: nobody → kdubost
The mobile website http://m.fotocasa.es pretty much looks and works the same way for both Firefox for Android and Firefox on FX OS. The first one misses a green (meaning "On") icon in a flat features list, while the second one lacks thumbnail photos in the results list. Other than that, both works OK.
(In reply to Ricardo Palomares from comment #2)
> The mobile website http://m.fotocasa.es pretty much looks and works the same
> way for both Firefox for Android and Firefox on FX OS. The first one misses
> a green (meaning "On") icon in a flat features list, while the second one
> lacks thumbnail photos in the results list. Other than that, both works OK.

Yes it's working when you enter directly the address. The issue is when you type http://www.fotocasa.es/ without UA override activated. It sends the desktop site.

The next step to do, if you would like to help, is to find the right contact at fotocasa and to contact them.  See also 
https://wiki.mozilla.org/Compatibility/Guide#Finding_The_Right_Contact_on_a_Web_site
and
https://wiki.mozilla.org/Compatibility/StdLetters#Spanish

Thanks a lot.
Flags: needinfo?(rpmdisguise-otros)
I've sent them this message through their contact form:

Hola,

Estoy ayudando al equipo de desarrollo Firefox OS de Mozilla a resolver problemas de Compatibilidad con el navegador del nuevo sistema operativo móvil Firefox OS (*). Hemos observado que, a pesar de que la versión móvil de fotocasa.es se muestra correctamente tanto en Firefox para Android como en Firefox sobre Firefox OS, su servidor web no ofrece la versión móvil a éste último, haciendo que su web no se visualice correctamente.

(*) http://www.movistar.es/firefoxos?pid=home1D1

Los detalles de las pruebas que estamos haciendo pueden encontrarse en este registro de incidencia:

https://bugzilla.mozilla.org/show_bug.cgi?id=828403

Específicamente, la cadena de agente de usuario que envía el teléfono móvil con Firefox OS es como ésta:

http HEAD http://www.fotocasa.es/ User-Agent:'Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

¿Pueden transmitir este mensaje a su equipo técnico? Si necesitan más detalles, pueden contactar conmigo para que haga de intermediario entre mozilla.org y ustedes.

------------

which, basically, tells them we've detected that their mobile website works OK, but that they are not serving it to Firefox OS cell phones. I've pointed to Movistar's website because that's what first appeared in my web history :-) and because that makes pretty clear that it is already a real product in the street, not a project.
Flags: needinfo?(rpmdisguise-otros)
I've received confirmation of message reception. So, at least, we can be sure the message hasn't been catched by anti-spam controls. :-)
Assignee: kdubost → nobody
Whiteboard: [uaoverride] [country-es] [serversniff] → [uaoverride] [country-es] [serversniff] [contactready]
Reaching out to the general manager on twitter. https://twitter.com/MozWebCompat/status/426068393171484672
Assignee: nobody → astevenson
Status: NEW → ASSIGNED
Whiteboard: [uaoverride] [country-es] [serversniff] [contactready] → [uaoverride] [country-es] [serversniff] [sitewait]
Response: looking to help, provided my email address and bug link.
Response: "the issue should be solved on our next release. Thx" https://twitter.com/marcelofpalves/status/426420040720986113
Latest test run says this is fixed, I agree. Karl - here's another victim for your UAoverride killing spree. Adam, congrats :)
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Blocks: 965060
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.