Firefox loses locale at first restart after an upgrade

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Raphaël Ouazana, Unassigned)

Tracking

18 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130107224926

Steps to reproduce:

When Firefox tells me a restart is needed because of an upgrade, I click on Restart button.


Actual results:

The locale of Firefox is now English instead of French.
If I restart one more time Firefox, the locale is back to French.


Expected results:

After upgrade, locale should be kept in French.
Do you use mozilla.org binary builds or did you upgrade with the packet manager of your distribution ?
(Reporter)

Comment 2

5 years ago
I used the packet manager of my distribution.
I thought that sometimes I saw the same bug on a stock Firefox on Windows, but I wasn't able to reproduce yesterday.
This can't happen on windows because Windows builds are single language builds. e.g. if you install a german Firefox build you don't have an english in the file.

Updated

5 years ago
Summary: Firefox lose locale at first restart after an upgrade → Firefox loses locale at first restart after an upgrade
It might be related to bug 818468.
Raphaël can you still reproduce this on newer Firefox versions?
Flags: needinfo?(raphael.ouazana)
(Reporter)

Comment 6

4 years ago
I will try on next Firefox update.
(Reporter)

Comment 7

4 years ago
Thank you, this seems to be fixed.
Flags: needinfo?(raphael.ouazana)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.